Main Site Documentation

Camera Streaming Button Issue


#1

Hi,

I’m streaming an image using ‘camera.StartStreamingBitmaps(cameraImage)’ and a timer that updates the display to show the cameraImage. I’ve got the fez spider and also tried on a power supply.

I’ve got two issues and I wondered if there were any solutions?

1/ The button event does not call every time - I’ve tested it on it’s own with no problems. I tried a second timer that ticks every second and it’s speed varies and is slow.

2/ The screen sometimes splits itself into four sections and it does not fix itself (happens even on the power supply as well).

Thanks.


#2

Can you take a picture and show us how the screen looks split?


#3

The button works better if I check manually in the same timer as the image display.

I’m using the oled display.

I’ve attached the image - it changes the way it displays every so often and is fine for the first few minutes.

There are extra frames of the same stream! Weird!


#4

Aha! it is the OLED not T35 display. Now things make sense.

The OLED code has a bug that we fixed (it didn’t reset the display on power up)

The coming SDK should have all these little issues covered.


#5

Sorry I should have said. Great - I look forward to the update.

Does this include the button issues?

Thanks again.


#6

Button was fixed in last release already. Maybe you do not have the latest.