Main Site Documentation

BUG in USB driver


#1

There seems to be quite a serious problem with the GHI USB debugger driver. I’ve noticed this on my Spider and Cerb40 boards.

Sometimes, during a deploy, if the deploy seems to be taking too long (minutes) if I unplug the device from the USB cable the PC will crash.

There is no bluescreen and no warning, the PC just resets and boots.

I’m running Windows 7 ultimate 64.

Can anyone shed any light on this?


#2

I have the same. The difference is that i get a BSoD (I think you might have this turned off). I have noticed this on my Cerberus board but didn’t play with it too long (waiting for the codebase to grow).


#3

Good, well sort of, at least I know I’m not the only person in the world with the problem.

I will check my bluescreen settings but I seem to remember getting BSOD for other things.

Trouble is this happens so often, probably 10-15 times yesterday by the time I had got tired of it last night.


#4

Sometime the long deployment ends with an error message like “Check your hardware” but if it doesn’t unpluging the USB cable will result in BSoD. I didn’t have this problems with USBizi or EMX though and you mentioned Spider which is EMX based.


#5

The driver is fine. Cerberus firmware could use some improvement.


#6

Ok, so exactly how does one update a Cerb40.

DONT point me at the Cerberus page because that doesn’t work.

How does one place a Cerb40 in boot mode? I tried pulling the boot pin high AND low, no good.

When can we expect a firmware that enables us to actually make the Cerb40 work for something?

At the moment its a nice red ornament. I could drill a hole in it and make a keyring.

(expecting a little more than a Gus one-liner here)


#7

According to hundreds (maybe thousands) it works :slight_smile:

As the catalog indicates, this is an in-progress software. You shouldn’t be even posting in gadgeteer forum. All discussions should be in beta forum as all these topics will be confusing to future readers once firmware is completed.

There are other boards that are very stable. I am sorry this this is not the answer you are looking for but we have to be clear so you are not making assumptions about the quality of GHI’s firmware. This is still in the works and you will have issues here and there till it is done. If GHI didn’t say this is out of beta, you shouldn’t be using it in a product. But we are not even in beta still, this is an alpha preview software :slight_smile:

You selected an open source offer which is developed by GHI and by community. Things take more time for free software to get stable. We are working hard on it and we appreciate any help form you and community to bring thins open software to life. Even with no contributions, GHI will finish it as we did with hydra’s firmware.


#8

How many thousands attest that it works for the Cerb40?

If I tie LODR high the processor on the Cerb40 gets hot.

If I tie it Low, the machine boots with the normal USB debugging interface

At NO TIME does the DFU tester recognise the Cerb40 so I can’t even erase the thing.

I recognise the rules and merits of open source, I am happy to work with the system as it is but at the moment, even given an alpha status the question of how to wipe and reload a Cerb40 has not been satisfactorily answered.

If this is possible, a Camera phone and a quick YouTube video would go a long way to encouraging “The Community”


#9

This is bad!! This maybe an indication that you have somehow damaged the board or the pin?

Why not start with Cerberus to ease your development and then switch to Cerb40 later? Just an idea.

Maybe I (and others) have missed your question because of the multiple posts and multiple questions? :slight_smile:

To set the chip in loader, you need to set the LODR pin, just like you are doing. There is nothing else to it. This is also not related to NETMF specifically, but a feature an loader built into the processor. Maybe check the STM32 datasheet?

We will try to get to it but anyone is more than welcome to make such video.


#10

Hi Gus,
Re damage to the board. As it was an apparently intermittent problem that had gotten worse over a few days I wondered if indeed there was some board damage. I “reflowed” the board with a hot air gun and it worked! I think there may have been a dry joint around the crystal oscillator. Interestingly, the horrible interference on my radio has gone too (The Cerb40 seemed to interfere a LOT with the signal) which sort of supports that theory.

The board doesn’t get hot any more when the LODR pin goes high. I take back what I said about the Cerberus technique not working.

I have now booted into STM loader mode and wiped the Cerb40.

Blimey what a rigmarole though!