BSOD in 4.2 framework, need VOTES and REPRODUCTION RECIPES!

If you’re experiencing BSOD issues with the 4.2 framework, then PLEASE VOTE FOR THIS ISSUE:

Possibly even more importantly, if you have a reliable reproduction recipe, I’m sure they would love to have it.

1 Like

Please do not provide repro steps with beta firmware. Wait till we have production firmware please.

Thinking about this some more, BSOD should not happen even with beta firmware :slight_smile: the driver and VS2010 should handle it better I guess.

VS2010 can’t cause a BSOD, and neither can any firmware installed on any devices you plug in over USB. Long gone are the days that userspace processes could crash Windows. Thankfully, nowdays, when you see a BSOD, there’s a really short list of things that could be wrong:

[ul]A bug in the Windows kernel
A bug in a driver
Faulty hardware that is triggering one of the above things
Faulty hardware causing unrecoverable system failure (such as failing memory)[/ul]

In this case, we’re certainly looking at a bug in the driver. The board is doing something weird/wrong/odd that is causing the driver to crash the machine. You’d be correct to say, “the board shouldn’t do anything weird like that”, but that doesn’t excuse the driver. No matter what, the driver shouldn’t crash Windows, regardless of what broken hardware did.


1 Like

FWIW, i had my Cerberus plugged in via USB for hours with no problems. While it was plugged in. I then performed the steps for getting 4.2. installed.
After that, i played with vs2010 for a bit. then tried to upload a new project to the board. it looked at thought it was hung up communicating with the board.
So i pressed the reset button on the board. when i did that is when i got the BSOD.
After a reboot, i tried it again, even creating a new project. again with same results.
After this, i upgraded the the Cerberus using ST loader app. tried it again with same results.
Then i changed USB ports, got a popup saying it found a new device. I tried it once more and that time it worked.

1 Like

I didn’t believe that a usb event could cause a BSOD. But, unpluggng my ceribuino after breaking VS2010 (express, 4.2 framework) it happened. I was getting long deploy times and an VS2010 gave up (Unable to communicate with device… ) bam happend to me. Nothing else was running, this computer (win 7) hasn’t had a blue screen in 2+ years.

1 Like

I installed GHI usb dev stuff and had BSOD within an hour of fooling with it. WOW is all I can say! I have never had a BSOD on this box before and I use it every day, 7/days a week probably avg 8hrs a day. Box runs 24/7 solid. I do a ton of embedded development using all kinds of tools/products an GHI is the only one yet to bring this box down! Nothing to be proud of for sure! Win7/SP1 x64

I’m going to try GHI stuff on another box I dont care about. I code for living and I cant have my code box being down cause of bad drivers. Any plans on GHI getting their drivers certified? I have to assume they are not!

I guess everything can cause a BSOD. The reason for some people to forget about this beloved message is because it can be turned off causing a reboot instead. I experience BSOD every now and then and it’s not only hardware related.

What device are you using? I thInk you are making assumptions quickly about GHI. Let’s get some info first. BSOD is related to Cerberus which is in beta still, otherwise, it is very rare to see BSOD.

I had a FEZ Cerbuino Bee plugged in, when this happened. The ONLY change to this box was installing GHI software. I run multiple VM’s on this box, thank fully only one was running. I’ve used this box running at least 2-3 OS’s daily for almost a year without failure. I code all day long in multiple VM’s with no trouble. Since removing the GHI development USB stuff, I have had no problems. I will provide you with any needed info, as I would like to test these devices but can not risk this box.

So it is exactly what I said :slight_smile: cerbuino and Cerberus are the same thing.
Latest SDK released few days ago in beta made this a lot better.

Need something stable? Stick to mature devices like spider(emx). The one you are using is in beta for few weeks still.

And welcome to the community.

just an FYI, it seemed to have trouble also making the USB device avail in the VM. Which is a great tool when working on so many projects. I will try this stuff out on another system to see how it behaves. Thanks BTW!

there is a known issue with the Hydra and VMs under Apple OS X. what OS and virtualization software?

@ Matt L - Welcome to the community!

Like Gus said, this is a known problem with the Cerbuino family of boards. I can confirm that it is getting better with each release though. I was able to reset & run at least ten times on a Cerbuino last night before I got a BSOD! :wink: (since you’re obviously knew to this you may not get the joke. It used to be every time you hit the reset button) Hang in there. The little puppy is growing up quickly.

@ Mike - I am running Win7Sp1 X64, VMware Workstation (8.x current) w/16GB Ram. Runs 3-4 OS’s very nice

@ Matt L -

OK. As I said, there were some issues with Hydra and VMs on Windows hosts that were resolved. I don’t know about the status of the Cerberus with VMs. GHI?

We do not usually perform any tests on vm

This issue has hit a lot of NETMF 4.2 users. We’re not sure why - the devs have gone through every line of new code and none of it should cause a BSOD on USB events. By all appearances something non-obvious is being triggered in the USB driver.

The plan for NETMF 4.3 is to switch to WinUSB which is much more stable:

Kerry, thanks for the update. The roadmap appears blank when I view it. Permissions?