Bricked Fez Spider


I’m here stuck with a dead Fez Spider. Yet again, I’m afraid :-(.

My setup is what the picture shows. The spider is the only thing that’s plugged in my usb ports. The display is white and there’s nothing listed in the device manager, not even under ports.

I’ve done a clean reinstall of everything on two different computers.
I’ve changed the gadgeteer cable
I’ve changed the usb client module.
I’ve changed the usb-cable.
My Cerberus, using the same usb cable, usb client module, and gadgeteer cable comes up fine.
I’ve checked and double-checked I’ve put the jumpers in the loader-position, ready to update the firmware.

I’ve tried to run this tool called “MFDeploy”, which I don’t really know how to use but which is supposed to control micro devices… In the “Device” drop-down it says “serial”, and there’s a “COM3” port listed - though that’s not listed under ports in the device manager. If I try and connect to it it says “Device is invalid or not responding”.

What’s a poor man to do…

Hope to hear from you.


Again? What are you to do, that’s simple… stop doing whatever you are doing to the poor Spider ! :slight_smile:

Sorry, gotta try to get some levity into the situation. Understand you must be upset.

Can you tell us about what happened between when it was working and when it stopped ? Were you deploying a new app (ie a changed app) or an existing older unchanged app?

So here’s how I would diagnose from here. First, I would triple check the socket you’re using for the DP module is right… According to Visual Studio, that should be socket 1 like you have it in, but make sure there’s no seating issue. Then if that doesn’t help, I would ditch the display and see if the behaviour is different. In device manager, you’re looking for either the GHI debuggable interface (in normal mode) or a serial port (in bootloader).

you sure you are plugging your spider into the usb and not a power outlet? just kidding :slight_smile:

do let us know what happened between it working and it not working…
I had some issues upgrading my spider, but it was really just a RTFM snafu on my part…and which Brett helped me fix, so do what he says :slight_smile:

Hello Brett,

thanks for your thoughts on this.

Not too upset, but the timing is sour - had thought I could get my robot up and running, and I haven’t got another Spider lying around and I need the mainboard with the most sockets. You’re certainly right in as much as I must be doing something wrong, since it’s the second time a Spider board has died on me. I can’t put my finger on what exactly I’m doing wrong, though. I follow the recommendations as best I can and unplug the power every time I change a module.

I can, I pulled the usb cable from the client DP module, as I have many times, as I was adding a button module to the mainboard. When I put the usb cable back in, the device manager never saw my Spider - it usually pops up very fast as a “debuggable GHI thingy” in the device list.

Socket 1 it is - and I’ve checked for bent pins and so on.

I’ve tried with and without the display, and I’ve tried with a different display as well.

But nothing in the device manager list, not under debuggable USB device nor under the ports list - there’s just the printer port listed.

Check out this thread started by me a few days ago. I was trying to use the WiFi_RS21 and had a ton of trouble. In the end I had to re-flash my Spider (a number of times) and now she’s working fine again.

No promises, but I didn’t know what else to do with mine and this certainly sorted it out…Good luck and let us know how you get on please.

Hello James,

good of you to suggest the thread you mention, thank you for that,

alas I’ve been there already, down the road of putting the spider in and out of bootloader-mode. But no matter what I do I’ll never see a COM-port, and that’s dire needed for flashing the thing… :frowning:

Hi, Are you running your computer in a virtual environment like VirtualBox or VMWare? I did, and couldn’t get it working either(same problems) I moved my dev environment to a native windows machine and all worked fine.

Have you tried to unplug the LCD? Sometimes it might draw too much for the USB port, or so i’ve been told. I don’t have a spider nor LCD module, but I’ve seen comments like that on the forum…

Hello Patrick,

no, it’s a regular Windows XP - no virtuality here. Thanks for the suggestion though.

Hello Errol,

I’ve tried with and without the display - and with a different display as well, just in case. Thanks for the suggestion, I’ve been there already :frowning:

@ harleydk - Please refer to to attempt manual firmware updating

@ James, I think the real issue is that even the serial port does not show up, so it’ll be hard to manually update the firmware until we can suss out why that is… ?

One of my G120HDR’s had a similar problem (i think)
It didn’t show up anywhere - no usb, no com, nothing in MFDeploy no anything…
I followed the procedure “TinyBooter Update through GHI Boot Loader” thru terraterm and hey presto all good again.
So just because Com doesnt show anywhere doesnt mean you cant get to it…i think…

PS Step 9. Windows will ask for a new driver. Driver file is GHI_BootLoader_Interface.inf didn’t happen for me but it still worked…

Hello Justin,

thanks for the advice, I’ll try and go through it in the same fashion as did you and let you know how it turns out,

thanks again,


Hello Justin,

I finally got around to it (kid got sick and had to sit with him in the evenings, thankfully he’s better now), but alas the steps which worked for your G120HDR won’t cut it with my Spider.

A damn shame but I guess it’s a goner. Would like to know what happened to it, but I’m not qualified for the autopsy :frowning:

Thanks for your help just as well.


I have no idea if it will help but I can say that I have had success doing the following on my PC. Although it is not running XP

I would first shut down the PC and change the Spider’s USB cable to a different USB port on your PC and restart the PC.
Been awhile since I had XP but I think it will try to load the USB driver the same as with more current Windows OS.

You may want to watch in the Device Manager to see if the USB port appears. Also try in the Device manager 'Scan for hardware changes’
I believe XP has that option. Right click on the top line showing your PC name.

Another thing you can try is the unplug the Spider USB cable. Press and HOLD the Spiders ‘reset button’ on the main board.
Plug the USB cable back in while holding the button pressed, wait a second or two and then release the reset button. (This has worked for me a few times).

Good luck and DON’T give up!

Glad your child is better! Nothing worse than worring about a sick child…

Hello Will, and thank you for the encouragement,

I had tried everything but the below advice,

but sadly this didn’t work for me. Very kind of you to suggest it, though I’d ‘massaged’ the reset button a multitude of times I hadn’t thought of trying to hold it depressed whilst applying power. So thanks for the suggestion.

I believe I’ve come to the end of my journey here. Shipping the Spider back to GHI is a no-go, as the cost of sending it back with a track&trace number is about the same as the cost of a new unit, so I won’t venture down that route again (the last dead Spider I returned alas never reached it destination, damn couriers!). If any of you fellas who happens to read this would like to have me send it to you, let me know and I’ll mail it through. It’s of course the cheapest if you’re in Europe (I’m in Denmark). Maybe you can win where I failed.

@ harleydk - Glad the wee one is on the mend.
I am happy to give the spider some CPR and if it comes back to life more than happy to send it back to Legoland.

@ Justin good stuff, let me have you address and I’ll send it your way asap. My mail is xxxxxxxxxxxxxxxxxxxxxxxxx