BrainPad install TinyCRL 1.0 how to get it into bootloader mode

With the help of a forum member i have been able to get the TinyCLR firmware. I want to install it on my BrainPad. According to the youtube video you can press the left button and then press reset while holding the left pad button then it will go into bootloader mode where I can use Teraterm to upload the firmware via a COM port. However no matter how many times i try i hold the left button and hit reset and nothing happens. the only thing that happens is the brainpad when i hit reset is the brainpad goes into a mode where i am able to access a small hard drive where i can upload Brainpad Make code files. I have my dev environment with visual studio set up but i can’t get my computer to detect the serial USB comport that i can use to upload the TinyCLR.

I went to the brain pad website on the section that says GO beyond and it says that is NO longer supported :frowning: . I don’t need offical help or bother the team at GHI electronics, If someone can just confirm that this is NO longer possible to do. then I guess that’s ok but I want to learn programming using my Brainpad.

Is there a special trick i need to do to upload TinyCLR into my BrainPad :slight_smile:

Thank you everyone

We have decided a while back to stick with makecode for now on the BrainPad. But we are going to get back to BrainPad and see what we can do for it in the near future. Right now, makecode is the only option since we do not have docs and download like you need.

Gus thank you for your kind reply. I’ve watched all of your videos on youtube and great work and inspiring… I appreciate the response and thank you . I will stick with MakeCode and thank you for taking time from your busy day to answer my question .

Cheers

1 Like

Hello, some boards enter the loader mode by holding the reset button down for 3 seconds.
Or try: Hold Boot0 Button and press Reset

Hello and thank you , the pad will go into bootloader mode :slight_smile: but What i am trying to do is use Teraterm to upload the firmware the :frowning: Unless there is a version of TinyCLR firmward i can drop inside the drive that gets created when you just hit reset

oh i know what problem problem is ?

you have uf2 bootloader installed on board and it could removed by clearing protection bits
with ST-Link Programmer , and to clear erase complete mcu.

there’s two “hole” (PA14,PA13) that need to add two pin to use St-Link programmer and to erase chip.

no first you need to install dfu bootloader by using this software

Seems that the former ways to get the Brainpad in DFU Mode do not longer work.
So there is now a software on the boards which prevents using functions which may have been the reason of a client to just buy this board?

Edit: Bootloader and Firmware can be actualized as usual (see post below). I only had forgotten how it is done.

yes i face this problem

need st-link programmer to remove protection bit from mcu to allow dfu file uploading …

1 Like

Thank you so much I am going to try this. this week everynight i tired my best to get TinyCLR installed on my brainpad but no success. I setup my VIsual studio but i can not upload the new firmward. iwill try the STM32 flasher and i will update this. :slight_smile: I if i can get this working i will make a blog post. and try to help other people. I really appreciate your help .

so i installed the software , but nothing happens. my braind pand won’t create a serial usb port that i can use as a COM Port to upload tinyCLR :frowning: .

I have try so many things and tried to follow this video

but the way he presses the left key and then the boot buttons does not work on my braind pad. So i can not communicate with it with visual studio ,. I feel this might be impossible to do per Gus’s reply, but I would love to use my brain pad in visual studio and expand my knowledge. :frowning:

Maybe i can use Embed programming instead. https://os.mbed.com/

I think that you need an ST-Link Adapter like this
-https://www.waveshare.com/st-link-v2-mini-stm32.htm

-BrainPad Arduino Code Programming via the serial SWD Interface
be careful to watch the picture. The blue wire is GND!

Edit: ST-Link Adapter is not needed. Bootloader and Firmware can be actualized as usual (see post below). I only had forgotten how it is done.

thank you for this . I love this community for their support of people like me who is trying to get his board to work :slight_smile: . I might try this this week going to go to microcenter and see if they have these devices or i will use amazon an order one. :slight_smile: Happy Sunday

Hi, I just tried to connect with this Wafeshare probe but couldn’t get it working. I still don’t know the reason.

Edit: Could connect with the Wafeshare Probe after pressing reset. Then I could erase the board with ‘STM32Cube Programmer’ and it showed STM32 BOOTLOADER under USB-Deviced in the Device Manger. Then all should work as shown in this video.
-Updating BrainPad's Firmware - Tech Talk 041

Hello Ro this is a great news. i placed the order for this device. I will be trying this tuesday when it gets here. Thank you so much. I would love to be ablet to use visual studio to program my brain pad but even if this doesn’t work this device is very useful to have. :slight_smile: .Thank you for this.

Did you get it working?
https://github.com/RoSchmi/BrainPad_TinyCLR_V1

Hello i was not able to get this working but you just posted these instructions and code :slight_smile: i am going to follow your instructions. Thank you so much. I really tried everything possible to get this working but it was impossible i will try this .

THank you

Hello , so tonight i followed your steps and it worked i was able to load the firmware on the brainpad. Thank you so much. These instructions were easy to follow and i was able to load the firmware.

There is only one issue i am having . Now when i plug the brainpad device manager shows a WinUSB device. if i click onteh usb notifications on the toolbar it shows the FEZCLR device attached.

I setup visual studio according to the instructions and setup all everything accordingly , but when i try to upload a simple program a hello world program. I get an an error saying

An error has ocurred please check your hardware. here is the error

Looking for a device on transport ‘USB’.
Found device port ‘USB’ with ID ‘fa1c4854-c0e1-4f88-a6a2-1a96e25c872e’ for transport ‘Usb’.
Starting device deployment.
Attempting to connect to device ‘USB:’: iteration 0.
The initialization of the debugging process failed.

I know we are getting closer :slight_smile:

Sometimes it is needed to repower the board by pulling the USB plug.

I disconnected this and reconnected it and it throws this hardware error. yet the USB shows the flezclr device connected to my computer . I feel i am close and will continue playing with this this long weekend.