Main Site Documentation

Board doesn't boot with SD and USB host connected and external power supply!


#1

Hi.

We are experimenting a weird effect on our Chipworkx dev board (1.5 release).

In our system, we have a Chipworkx board connected to USB device (i.e. chipworkx is usb host) and a SD card inserted in its slot.

In such configuration, when we reboot board during develop/debug cycle everything is fine.

When we try to power-up the system via external power supply nothing happens: the display turns on but instead of showing booting splash (i.e. tinybooter and tinyclr messages in green on black background) it shows a blank, white, screen, and boot doesn’t go on.

Resetting or power-cycling the board has no effect.

To restart the board, we have either to disconnect USB cable (the one that connect chipworkx as USB host by its USB device) or extracting the SD card from its socket before reconnecting power-supply.

We tried with several power supplies (different voltages and current level capabilities) with same result.

Any suggestion?


#2

I have never seen this before. I know CWX boots from SPI/dataflash and I think the SD card is on the same bus so maybe this SD card is somehow causing problems? But how is this related to USB?!

Is there a file on SD card called boot.bin? Format the card and try again please.


#3

Solved. It was a damaged SD. Apparently everything was fine with it, but after having inserted and extracted it from my PC SD Card Reader several times, it has literally burned!

Despite my fingers pain (it was really hot), I am glad this annoying issue has been solved…