Beaglebone Black Wireless modem issue

Hello everyone,

I’ve been using Beaglebone Black Wireless OK for almost 2 months, until recently where I ran into an issue with the WiFi modem not working at all. I’ve used bone-debian-8.6-iot-armhf-2016-11-06-4gb.img
What happens is: we load our application that uses the WiFi WL1835MOD on the board & everything seems to be fine for a while, both BL & WL LEDs turn on. After we run the application for maybe 10 min. to do some GPIO/ADC measurement then restart the system the WiFi chip stops & doesn’t turn ON at all. Both LEDs are Off at this stage.
I’ve checked the 3.3V_WiFI & 1.8V_WIFI voltage rails and they all seem to be fine as expected. However, The WIFI_EN signal which is connected to pin#40 “WLAN_EN” on the WiFi chip, which is also available at the gate of T3 MOSFET has 0V, this means the microprocessor is not turning the modem on for some reason.
This happens to 4 out of 6 boards and that is really high.
We tried to reflash & reloaded our original image to start fresh but again the modem doesn’t turn ON because WIFI_EN signal is still turned off.
The same thing happens to the Bluetooth, it is OFF & BT_EN is at 0V.
We’re using a 5VDC supply rated for 2.4A. The boards are brand new & never used before.

Your feedback is highly appreciated.


The boards that are bad are always bad no matter what? And the good ones are always good?

Have you tried a different software version just on case?

Note that the BB experts are on their forum but we will try to help if we can.

I’ve 10 brand new boards, when I urn them all on, WiFi is good. Then, load the image, start using WiFi for almost 10 min. Restart them all then 4 out of these 10 WiFi is gone.
The good ones are always good but that’s not guaranteed.
The boards don’t come with any date code so I can’t trace them back to certain batch #.

Yes I tried a different version but with no luck.
I’ve already posted this on TI’s website but I guess you guys manufacture the microprocessor, right? The enable signal comes from the microprocessor & the WiFi modem I think might not be the source of the issue.

Appreciate your help.

This sounds like some software issue.

I’ve already posted this on TI’s website but I guess you guys manufacture the microprocessor, right?

You need beaglebone forum