August 24th, RC2 for NETMF 4.2 QFE2

No, please see


I want to upload 4.2 EMX TinyBooter to the old Embedded Master module. After the successful XMODEM upload, the USB connection didn’t work, mfdeploy didn’t see the device. But, if I upload the 4.1 TinyBooter from 4.1 SDK directory, everything is ok, usb connection work, and I able to deploy the firmware.
What’s wrong? Help me pls!
It is possible to use the 4.1 TinyBooter with the 4.2 firmware?

thx, Gery
from Hungary

@ ggyano - Embedded Master was discontinued years ago and so we no longer support it with latest software but you can continue ot use older software.

Welcome to the community.

Hmm… seems is down at the moment. Anyplace else I can get the NETMF 4.2 QFE2 bits?

[edit] it’s back now… has anyone ever seen codeplex totally offline like that before?

hi guys,
i noticed that the USB Driver included in this latest beta, takes a long time for the SPIDER to reconnect which causes failure for deployment…
basically if i have a hex file and try to deploy that using MFDeploy… when i click Deploy MFDeplopy erases the devices reboots and then it sits there and gives an error (Unable to deploy to device) , and as soon as the error is displayed windows makes the ding sound and the device appears so it is like timing out…

not sure why you guys added the delay, but it is too long i think…

can we just install the WinUSB from codeplex and use it?

Edit: the same thing happens when i hit reset basically windows take a good 5 to 10 sec to reconnect the device where in the past it was almost instant…

I know that you guys are trying to fix things but most users here would appreciate a good release note that explains what has changed and why… as you may have noticed we waste a lot of time debugging thing that we shouldn’t be debugging so at least some help along the way would be nice. and I’m just saying… because now i don’t know if my Spider is not deploying because of old symptoms or new symptoms or both…


We actually noticed the delay after release … Long story short, this is not intentional and we are trying to fix ASAP.

It should be simple, even trivial to compiler SQLite for Hydra.

Gus, Thanks for your answer. It makes me very-very sad, because I’m waiting for 4.2 for a long time.

So, I will modify my hardware to use G120…

A typo: when I want add a reference in Visual Studio 2010, there is a GHI.Premuim.SQLite in the list.

@ godefroi - Hi, can you enlight to me, to compile SQLite to work with Hydra? lerg98

Thanks for the note

I got these messages when debugging a Gadgeteer project on Cerberus:

Warning: socket 3 is not compliant with Gadgeteer : Socket of type O must support analog output functionality
Warning: socket 4 is not compliant with Gadgeteer : Socket of type O must support analog output functionality

Is it normal?

@ jango_jas -

See the following thread:

I guess the same answer applies here.

The After-release known issue for Cerb-Family Ethernet has been resolved with Firmware version which can be found on the original post here:
You will need to re-flash the board, including the TinyBooter, as the change affected this as well.


I own a Spider for 2 weeks now, and having great fun!
Time to update to the latest and greatest, so here is my experience;

I am not able to do a firmware upgrade on a MacBook Pro 2012, running Win 7 Ultimate x64.
Everytime I set the dip switches to “Loader” and press the Reset button, I get a “USB device not recognized” windows balloon.
Not able to run the firmware upgrade.

So, I did the same update on another PC running Win 7 Ultimate x64.
This time it succeeds. The T35 display shows EMX Version

I am able to develop, deploy and debug on both PC’s with NETMF 4.2 now; So far so good.
Now let’s try again on the MacBook; dipswitches to “Loader”, press reset button; The “USB device not recognized” windows balloon shows up again.

The difference between the 2 PC’s; USB 2 vs USB 3

Have nice day,

@ Lambertus - Welcome to the community.

Spider uses CDC class for the boot loader. It should work on mac as it is standard but we have not tested it on mac.

Are you running in a virtual machine or are you using Bootcamp?

Bootcamp. Running latest windows patches.
I tried with different USB cables, with/without external 12V power, with/without 35 display.
Restart PC and so on.
There is connection when running the Spider in normal mode, in loader mode it fails (unknown device).

My workaround is to use another PC when doing a firmware upgrade,
but there might be users who experience the same problem.


@ Lambertus -

Sometimes it helps to remove the device from the device manager and then plug the device in again.

@ Mike
Your device manager suggestion made me realize to compare the 2 computers.
I found that on the working PC, the spider shows up under Ports (COM & LTP) -> GHI Boot Loader Interface (COMx)
So, I knew where to look.
That said, plugged the Spider on the MacBook again and guess what, it found the device and it worked.
I was able to do a firmware upgrade !!??

Then I pressed the reset button again … bad luck, reset again and again and again and suddenly it connects.

Tested a hundred times (reset button / plug the cable);
I need to press the reset button 2, 3, 4…10 times before it works.