Anyone get their G120 module running?

I tried hard not to make this post, but I am out of ideas.

I built a custom board for the g120 and no matter what I try. I cannot get them to boot (detected as a USB device)

I followed the reference design and believe to have all required connections. However at the bare minimum, I would expect that 3.3v, GND, reset pin pulled high and of course the USB d- and and USB D+ (to client USB) should be all that is required for the computer to recognize the module.

The unit has power. I am read 3.3v output voltage on most of all the pins, except the USB pins and a few others. However, thats as far as it goes.

Has anyone else been able to get their modules working (NOT HDR)?

Moderator: please edit thread title to “Their”

How many modules do yo have?

You only need to check: 3.3V, GND, reset, LDR0, LDR1 and MOD which I believe they are marked in red in brochure. Maybe VBAT is causing problem so connect to 3.3V?

I have two modules and I have tried them both.

Regarding the MOD pin. Do you need some kind of signal feed to it? I thought just leaving it floating would result in USB debugging mode? The only connection I saw to the mod pin on the reference design was to a header pin.

My guess looking at the G120 brochure is that the MOD pin needs to be pulled high for USB or to GND for COM1. I don’t think it should be left floating.


Not based on the reference design…

Regardless, I just tried it with no change.

Well I think I have done everything I can think of. There is only but so much documentation ( connect this, connect that end of story). I have gone over it 20 times. Its pretty straight forward.

I have spent over 12 hours on trying to get these modules working.

Either something is missing from the reference design, the modules don’t have the firmware/bootloader, or my modules are DOA.

@ BrightIdea - have you tried talking to it via terraterm?

I wish that I could. The PC isn’t detecting it in anyway shape or form.

Its as though its not booting.

One of my HDR’s was MIA an didnt register anywhere following GHI Electronics – Where Hardware Meets Software did the trick and all good.

I would have thought the module is identical to the HDR - the sockets.

@ BrightIdea - my PC didnt detect it either

Thanks for the tips Justin, but its not showing up as COM port regardless of how toggle/hold the switches.

@ BrightIdea - Are you talking about device manager or TerraTerm?
Mine didnt show in device manager at all but in TerrraTerm there was a com port and away we went…

@ Justin: I checked both, no diff.

One thing I have found, which may be meaningless is that Pin 67 (Client D-) is being held low. If I put 3.3v to it., the computer recognizes the connection of a USB device, but says it is unrecognized.

@ BrightIdea - hmmm…I have left the office for the day but if no joy tomorrow I can try some diag on one of my hdr’s if that might help.

@ BrightIdea - Did you try pulling LDR0 and LDR1 low and then powering it up to see if it enters the 'GHI Bootloader" mode?

Pulling D+ and D- up or down, depending on the combination, tells the Host controller if a device is attached and what speed to run at. Sounds like your tricking your PC into thinking somethings attached when it is not / not responding.

Do the modules ship with firmware installed?

This is a bad idea, for the module and your computer :slight_smile:

I will send you an email in a sec

If not firmware then at least TinyBooter. Either way, you will see something on USB.