ALFAT with a lot of files in one folder


I’m using an ALFAT to write a lot of files to an USB flash drive. The files will be written in different folders. The problem is that I receive errors after command “O” in dependence on the number of files that are still written in the same folder. If I wait some milliseconds after sending command “O” it is possible to write more files before an error appears.

Some examples:

create a folder
create some files
wait 200 milliseconds after each command “O”
error appears after about 50 files

create another folder
create some files
wait 500 milliseconds after each command “O”
error appears after about 80 files

The longer I wait the more files I can create without an error.
I tried it with different flash drives, every time the same result.

I have seen you have heard about the problem some months ago.

But I can’t found a solution in the forum.

My firmware version is V2.0.0

What can I do?


@ s_kohlhage - The thread you mentioned didn’t receive any errors, it just took longer to open the file. What errors are you seeing?

You should not wait with a fixed number timeout. This does not only depends on total number of files in a folder but also depends on your media.

After send ‘O’ command, poll your RX until you get something is a best way, I think.

We are investigating this issue but even there is a solution, this time out is not same if different media.