Main Site Documentation

Alfat -sdr 1.2


#1

Good afternoon,

I have just received the ALFAT Evaluation kit which comes with the ALFAT-OEM card and the ALFAT-SDR card. From reading the website, I assumed that I would want to use the ALFAT-SDR card for a simple data logging experiment. Since this was my first foray into the SD card world, I just wanted to see how easy it was to talk to the SD card. It was, using the supplied ALFAT explorer I got up and running in very little time. I moved on to trying to send commands through Hyperterminal, also up and running in very little time. All this was done using the EVAL board with the SDR board plugged in. The computer was plugged into the Virtual Terminal Interface and an SD card on the SDR board. So the next thing I tried to do was to use the SD Card Reader mode.

It is here that I could not figure out how to make it work. I tried plugging a second USB cable into X2 of the SD card, did not get it to work. Then removed that and tried it in “Host Connector For ALFAT-SDR Only” on the EVAL board and couldn’t get that to work either.

So I changed over to the ALFAT-OEM board. I plugged the computer into the “Virtual Terminal Interface” and then another into the USB1 (top) spot. I used the supplied program and Initialized in Card Reader mode and the blue light came on, the computer recognized the SD card as another drive and I could access the files.

Can someone point me in the right direction for the other card? I think I just don’t have the cables right but can not find any documentation on how it is supposed to be. I just may be over looking something.

Thanks for any and all help.

Steve


#2

@ Bad Steve -

did you send “I D:H” command?


#3

Dat thank you for taking the time.

The answer to your question is yes, I sent the command using the supplied software, ALFAT explorer. Can I assume from your question that If I have the ALFAT-SDR-1.2 board connected to the ALFAT-EVAL board, I have one cable plugged into the “Virtual Terminal Interface” and another into X2 on the SDR card, I should be able to get the SD card reader mode to work. I will try that again but I have tried that in the past.


#4

Dat,

You are a genius, That did it. Using the ALFAT explorer software, it would not work by just clicking on SD reader. I noticed in the terminal window, the command sent was I D: and the command you posted was I D:H. So I tried that command in the custom command entry box and viola, the blue light came on.

Thanks for your help.


#5

Thanks. I will show this post to my wife.

:smiley: