I have something weird going on.

On some of my boards, ALFAT-OEM 1.3 are not working but ALFAT-OEM 1.2 are working. When the ALFAT-OEM 1.3 isn’t working, I am often getting ? sent to me by the ALFAT at 500,000baud instead of an echo. I am using the UART interface.

What can be causing this?


Run the baud at 115200 and tell us what you see back please. Also try at 9600.

What do you have connected to the reset pin?

There’s no using trying 9600 or 115200 or any other other baud rate because I don’t even get the splash screen.

I don’t have the exact schematics right now, but something like a diode and pull-up combination that grounds the reset pin when I want to reboot. I checked with a scope and reset pin is working.

Really feel like the ALFAT is in a funny mode since it’s giving me ? at 500000 baud.

@ da66en -

Those boards are not working at all, or they just don’t work when change to 500000?

They don’t work at all. The only thing funny going on is that when I send a character to it over serial (doesn’t matter what baud rate), it responds with a ? at 500000 baud.

@ da66en -

is there any way to test those boards with Teraterm application on PC?

The board sites not boot in your baud. We also need to know how is the board being reset and how the uart mode is selected please.


I know you’re trying to help, but I already answered the reset question above.

Going into UART mode by grounding those 2 pins, of which I can’t remember right now.

Maybe. What do you want to try?

You say you ground the pins but you do not remember.I am confused.

Also the default baud rate is 115200 so I am not sure why you are using a different baud rate.

We also need too see how the reset is connected. I think we added a pull up in the latest version.

@ da66en -

Simple and easy:

  • Leave all pins of ALFAT unconnected, except for TX, RX, 3.3V, GND.
  • Make sure that the Reset to high, you can connect to 3.3.

Open any PC software that support serial port, TeraTerm is one of great application for this.
In PC, set up that application 115200, 8 bit, Parity None, stop bit 1.
Now you can send few commands from that app and ALFAT should responds.

Once you get successful with this step, then we can talk next thing, right now I don’t know where your status are.

When you get a “?” back, really all you’re getting is a whole heap of characters mashed together at the wrong baud rate.

As Gus said, you need to get the banner working, at the standard baud rate, before you can switch up the rate.

No, no, no. At 500000 baud there aren’t several characters mashed together. It’s one ? character at 500000 baud. I verified this with a scope. This fact seems to be ignored. This really seems to imply that the unit is in some kind of weird mode, and I would have thought it would have been a clue to the developers as to what that mode was.

I just got the schematic (had to wait until after the holidays to hear back from the hardware designer). The RESET pin is connected to my MCU’s GPIO via a diode, so my MCU can ground the reset pin. I verified with a scope that it pulls it down. The only glitch is that the voltage doesn’t get pulldown to a full 0V, I will check the datasheet to see if there is a minimum voltage needed and if I’m not getting that low.

I AM NOT USING A DIFFERENT BAUD RATE. I am using 115200 and getting a ? response at 500000 baud.

@ da66en -

Look like I am confused. Your MCU is 115200 or 500000 baudrate please?

My MCU is using 115200. The ALFAT is responding with ? characters at 500000.

@ da66en -

If MCU is 115200, ALFAT default is 115200, so what device did you setup at 500K baudrate?

Understand, you probably looked at scope?

Anyway, are you done with my post #9?

Problem solved.

On the boards that didn’t work there was something (pull-up or pull-down, can’t remember) on the BOOT pin. It’s there on the old boards because they were originally designed for the USBWIZ version of the OEM board. However, with error on the BOOT pin they still worked with ALFAT-OEM 1.2 and not ALFAT-OEM 1.3.

I’m guessing the ? at 500000 was due to the unit being in bootloader mode.

I’m surprised that in a forum full of GHI employees and experts they couldn’t point out to me what the changes were from ALFAT-OEM 1.2 to ALFAT-OEM 1.3 -AND- that the bootloader puts out ? at 500000 baud.

I repeatedly tried to help but I still do not have an answer from you. What exactly you have connected toy the reset pin? How do you reset the board on power up?

I answered that question twice. And it had no relevance to my problem.

@ da66en -

The boot pin should not be the problem. no matter what level is, ALFAT should work even that pin high or low.
That pin is pull down on both ver1.2 and 1.3.