Adding USB wifi to the OSD3358

The easiest way to add wifi to an OSD3358 is via the USB host interface. A host interface is built in on the development system but requires additional hardware for the TH and SOM. At some future point, I’ll show how to use something like the CC3100 or RS21 to get native wifi without USB, but this is the most expedient route to wifi:

http://kb.pervasive.digital/Home/Detail/adding-usb-wifi-to-the-osd3358-(default-debian-distro)

I have only tested those instructions with Debian lxqt 8.4. They will probably also work with Archlinux.

4 Likes

Ethernet will work as well right? Except just plug it in.

Did you use the TH board and solder a USB host connector to it? Can you post a picture of that please?

@ Mr. John Smith - On the development board, yes, the ethernet PHY is there. I have not tried adding the Ethernet cable to the TH.
@ Gus - I used the dev board to work out the software side of things. I have parts on order from mouser so that I can add the USB host adapter (and a few other things :slight_smile: ) to the TH board.

1 Like

@ Gus - I have to do that soldering (I ordered the TH board, it arrives today). If I’m not too tired I’ll do it today and post a picture.

Actually, I have to solder in a hub as well so; we will see.

1 Like

Can you wire up the USB host port ‘naked’ without the ferrites, ESD and solid-state switch?

fwiw, next up for me is CAN bus (as I have immediate application for that), and trying out Snappy and Yocto distros, as they are more IoT-tuned distros. That work will all continue to show up as kb articles.

@ mcalsyn - yes just the connector. I think this is what dat did.

1 Like

@ Gus - I’ll definitely give that a go then.

Well it it finally arrived.

2 Likes

What’s cookin doc? :slight_smile:

@ EvoMotors - Dog soup.

Are you in Korea?
https://en.wikipedia.org/wiki/Bosintang

1 Like

Not only in Korea…
:slight_smile:

@ mcalsyn - I managed to get the wifi module to connect to the beagle bone TH module however the command scan wifi never completes. How long should I wait?

Ok it completes but it gives an error. It seem the bbb is already acting as a wifi access point by default. Do I need to turn that off first?

Well there goes 2 hours I’ll never get back.

Yes, you have to disable tethering for it to work. Check the status of the Tethering by entering “technologies” while in connmanctl. If it is on then exit connman, and at the console enter : “connmanctl tether wifi off”

Go back into connmanctl then say scan wifi.

Ok, it’s finally on the wifi network and connected to the internet via the hub.

The TH Module is a success!

This page also helped

https://gist.github.com/kylemanna/6930087

the important bit was the part about creating the file. See where it says ? Thats where you put the hashy part ( e.g. 74da386d0366_4b7573616e616769) not the service name part (e.g. wifi_74da386d0366_4b7573616e616769_manged…)

2 Likes

Excellent! I didn’t have that same problem with the tethering - not sure why we had a different experience there, but it might be related to using different wifi dongles (though why that matters for this mode is not clear).

Anyway, I will add that to the KB article.

1 Like

@ mcalsyn -

I will add that to the KB article.

Sir, could I ask where the KB article can/will be found?

Thank You for sharing you knowledge and time.

@ willgeorge - the link is on the first message in this thread.