Main Site Documentation

Accidentally selected clean, now cannot deploy


#1

I have been using VS2012 to update code to a Fez Cobra, and I accidentally selected Clean instead of Deploy from the menu, and now I can no longer Deploy. Error message says GHIElectronics. NETMF.Fez.pe was not found. Anyone know what the issue is?

Thanks.


#2

try rebuilding the solution/


#3

I have. Still get the error.


#4

Are you targeting 4.1?


#5

I am, yes.


#6

and there are no errors in the output window?


#7

Yes, two errors. Cannot find the FEZCobra_GHIElectronics.NETMF.FEZ.pe file and the GHIElectronics.NETMF.Hardware.pe file in the debug/LE folder. I have tried copying these two files into the debug/LE folder, but when I build or rebuild they both disappear again.


#8

I reinstalled the 4.1 SDK, that seems to have resolved the issue.

Thanks!


#9

cool


#10

Actually, this didn’t completely solve the issue. The problem is with Build, not with Deploy. If I close the project and reopen it, then it will build. But only the one time. Next time I go to Build it gives me the same errors, and I have to close the solution and reopen it again.