A little help setting up

yes (bootloader mode is 4 off, 3 on, 2 on, 1 on?) The triangle shows the driver does not work.

If all pins are off the driver works as expected and reports no problem.

No, when the switches are changed, a different driver is used.

I have followed the instructions from the FEZConfig and moved the pins as instructed to update the tinybooter. Moving the pins back to how they were when i received the board show the same error in device manager.

Here is a screenshot if that helps.

Hi, but what happens when you uninstall the driver and remove the files, like I mentioned about 6 posts ago?

The same thing, I have removed both files and drivers around 5 or 6 times now, it seems to make no difference.

so tell us how you reinstalled the driver?

I removed the usb driver via programs and features and reinstalled via the GHI 4.3 SDK installer. I have also tried the legacy drivers and that did not help, so using the same method above I reinstalled the newer drivers.

I have also used the GHI installer to remove everything that it installs rebooted and reinstalled, which has made the board show in FEZConfig now which is good I think.

If I use MFdeploy I can ping the device and get a response back which I think is also promising?

The firmware has updated, when I run config it states that the tinybooter is and is out of date.

Firmware is now and is upto date.

I know have a led that lights up on a button push ;D.

Now to fix the board that is not recognised at all.

Thank you for your help.

David, you really need to have the bootloader and the firmware to match.

To properly uninstall the driver, you need to connect the device in it’s failed state, then in Device Manager go into the driver properties, driver details, then uninstall from there. I don’t think uninstalling the GHI SDK will remove the driver.

Brett, I have removed the drive via device manager, reset the device and reinstalled the driver. it is still in a failed state. I then went to update driver and it showed the GHI Bootloader Driver. I accepted the update but the update failed due to the error

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

I will try this approach a few more times to see if I can make it stick as it seems forum members suggest this in other posts.

I have now removed the bootloader driver via device manager, then went to programs and devices and uninstalled from there to remove both drivers. Rebooted the computer and reinstalled the drivers via the GHI SDK.

In debug mode the board works as it should and shows in FEZConfig. The LCD shows the correct information too.

I then moved the pins to loader mode and waited for windows to install the bootloader driver. Same error message as before but I manually updated the driver and am not getting another error message (see attached picture). I did this with the LCD connected to the board and the screen is white.

I then removed the LCD and removed the driver agian via device manager, reset the board and let windows look for a driver, device manager reports that no driver can be found so I searched C:\PROGRAM FILES\GHI ELECTRONICS\GHI NETMF USB DRIVER SET Which again gave me the same error when the LCD screen was connected.

Forgot the pic!!

What part of the world are you as if there is someone local that might be able to help?

Bill I am in Lincoln UK.

Hi David, i have sent you a PM…