Main Site Documentation

A little help setting up


#1

Hi I am a 3rd year computer science student, I purchased a spider stater kit to use for my final year project. I am using windows 8.1 on a macbook pro under bootcamp and visual studio 2012.

I have installed everything and followed the instructions to set up the spider. Once I got to updating the firmware, the tinyBooter failed to deploy and now my board cannot be seen by windows. Device manager is showing GHI boot loader interface and is giving the error (10)
the device failed to start. I have been on the forums and tried reinstalling the GHI SDK but this has not fixed the problem, changing usb ports and all other suggest fixes I can find.

I have been trying to get it to work all day and any help would be greatly appreciated.

Thanks


#2

have you read this document?

https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#3

Yes I have read this document. I have tried to manually install but teratera does not see my com port.


#4

So after looking around some more, I’m pretty certain its the USB driver that’s not installed properly.

The error is the device cant start, removing the driver and manually installing it does not help at all. If I unplug and plug it back in, windows makes a sound to say something is there.

FEZ config will not find the board and device manager is giving me a yellow triangle.


#5

I have now done everything that the trouble shooting documents suggest and the problem is still not fixed. it seems that the GHI Boot Loader Interface is not going to work at all even with the pins all off and with 4 off 3 on 2 on 1 on.

I feel like I am completely missing something but it would be good if someone out their could at least point me in a more detailed way as I have now been trying to get this to work since 10am this morning.


#6

Ok so this board wont work at all even with the pins off. I have borrowed another spider board and tested it on my computer, it seems that the usb is found correctly and can be found by FEZConfig but when the pins are moved to the loader mode then I get a triangle with a warning and the device is no longer found.

when i point my driver to the GHI file I do not have a usb folder(see screen shots). I have now been trying to get this to work for 11 hours with no success.


#7

What exact error does Device manager show if you double click yellow triangle entry?
Can you try it on another computer (may be no MAC)?


#8

Thanks for your reply the error message is

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

I only have access to a mac as it is the only computer I own, I can use the computers at uni but they are ghosted everyday and the gadgeteer framework is not installed on them by default.


#9

I have this error code sometimes on an internal USB hub.
In my case it helps to deactivate and activate the device in device manager.
But I also had the same error on a different computer for an audio device where this did not help. But a reboot did it there.

b.t.w. you dont’ need the full framework installed for FW update:
Drivers, FEZConfig and the firmware files are all you need.


#10

Both solutions did not work windows is now reporting a unknown usb device with configuration descriptor request error

the error code is

Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB configuration descriptor failed.

moving the board back to a power usb hub it is giving the original error again.


#11

Also plugging in the touch screen that came with the starter kit I get a white screen displaying if that helps.


#12

Do you have an extra power supply for the board, or is it only powered by USB?


#13

I have used both a powered usb hub and a powered supply both without success


#14

USB is one of the most time-consuming things to setup when there is driver problem. I think you should try searching on this forum for USB issues and ideas.


#15

I have been searching on this forum since 10am this morning, I am a competent coder and at times problem solver. I have exhausted all the topics I could find but can not get this to work at all.

It is a tough one as I am sure it will be something simple but I can not seem to get this working and have bricked one board today that now will not be seen by the computer in any state. I think I’m ready to give up and get my arduino out.


#16

I know how it feels. Calm down and wait. I think someone here might have some tips for you.

Arduino will give you more trouble. Believe me.


#17

I think the tinybooter is invalid maybe try the teraterm way and re-install the tinybooter. Just thinking. ??


#18

What I think this really requires is to uninstall the bootloader driver and make sure you remove the files. Then, reattach the device and reinstall the drivers from the SDK directory when prompted. Then I’d do as @ njbuch suggests and go to manual firmware installation.


#19

I have tried the manual way, but the com port is not available for me to select. if all 4 pins are off the board will be recognised, If I change it to 4, off, 3, on 2, on 1, on then the board is not longer attached to the computer dues to the driver.

I have tried to use VS 2010 (I’m a student, free software :D) which is great but the gadeteer visual designer is not available in 2010. (at least not on my system) I would happily remove VS2012 and try and get it working with out an update, but we have a Windows phone 8 module this year and is VS2012 is needed for that. If I can get gadgeteer working in VS2010 and use VS2012 for phone and asp development, it would be the best of both worlds.

I also have attached the LCD which is working and is reporting version 4.2.7.0 if that helps


#20

Hi again David,

when in bootloader mode, does the driver still not load? (i.e. show the exclamation in the triangle). That’s the only error you need to get past right now. Don’t worry about VS versions yet, lets get your driver running - you will be perfectly fine with VS2012, but it won’t influence this driver not loading.