A Big Problem with Hydra fw Updater

Please make reference to this topic: http://www.tinyclr.com/forum/topic?id=10379 where I had problems with an Hydra, because the system cannot recognize the USB device in no way. At the end, with the help of andre.marschalek and Aron, we understand that there was a problem in the Atmel boot program.
Now, I purchased a new Hydra. First of all, I installed the VS2010, then the SDK4.2 and finally the GHI NETMF 4.2 (all packages).
At the end, it starts automatically the Hydra Updater and asks me to connect the board. Ok, I connect the Hydra to the USB Hub and it works, because the display TE35 shows me some start-up messages. To be sure, I go to Device-Get Firmware version and I see the current version is
All seems ok to me… now I can press the Update button: ok… it starts with memory erasing procedure … and after a few seconds a red message appears (unfortunately I closed the window of the program and I cannot replicate it) of kind “cannot connect to the board” ! I look into device manager of my pc and found the same problem of the first board: USB Device Not Recognized !! I think that there is a problem in the Hydra Updater Program… it seems like it erases even the embedded USB code… Please help!

Can you let GHI know whether you have done this on the SAME PC as the previous one, or a different one?

It seems extremely strange that you have the same failure on two different devices. And I don’t want to discount that you have a problem, but we haven’t seen many other issues like this explicitly on the Hydra Updater app.

Can you give us the details of your PC again, Windows version, age of hardware, USB ports? Can you also please step through the manual update process and show us the screenshots from Device Manager at each point.

Edit: I did also want to note that I think Gus mentioned that the Hydra is the one device that didn’t get an updated WinUSB driver in the latest 4.2 SDK

Yes… obviously I can fill another RMA and this is the thing that I will do asap… but now I understand where was born the problem of the first board because it is the same issue of the second board, happened during fw updating procedure.
It seems very strange to me that two boards have had the same problem with the fw updating program, and I want to understand why… because I cannot go on filling RMAs every time I try to update the fw of a new Hydra

@ andre.marschalek: the link to that topic is very interesting because it seems that other guys have had the same problem !! Now I go to read deeply that topic, and then let you know.

@ Brett: the PC is not the same of first time, this is a new DELL VOSTRO with Intel i7 processor, 8GB Ram, and Windows 7 pro. I connected the Hydra to the USB port of the HUB integrated into the monitor. I tried all manual udating procedure but I cannot go on because the USB port is not recognized (see attached picture… sorry it is in Italian language, but the first line is “device not recongnized”)

[quote=“DiegoIT”] To be sure, I go to Device-Get Firmware version and I see the current version is

This doesn’t sound right for a 4.2 update…

What happens if you do use either an SD card to put it into boot loader mode or short the SPI pins to get it into boot loader mode?

I tried both with the SD card procedure and through shorting pins 8 and 10 of socket 3… nothing happens :frowning:
By the way, I just tried to install of the software package into an XP machine… as I suspected, it still doesn’t work. The issue is the same of cayrol272 and zakhounet in this topic: http://www.tinyclr.com/forum/topic?id=9532&page=6 but I really don’t understand if they solved the problem and how…

@ ianlee74: do you mean that the fw updating program doesn’t work if the old fw version in the board is ?? Is it too old for being updated in this way ??

Do you have an "Debuggable .NET Micro Framework Device " under Devices And Printers?

No I haven’t… when I plug the USB it appears an “unknown device”, that disappears when unplugging…
The same happens when I short pins 8 and 10 of sock 3 and remove the short after about 5 seconds…

@ andre.marschalek: No, it is not possible. When I try to select driver manually (those in the folder C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface) it says “Not possible to install unknown device”

@ DiegoIT

What are the board rev numbers found on the bottom left of the board? Where did you buy them from?

Sorry, I thought you were saying that was your fw version after doing the update. That should be fine if that’s the prior version.

@ Aron : This board rev. is 1.2, purchased from Mouser, whereas the first board has been purchased from Antratek

…someone has another idea for helping me ?

@ DiegoIT

This issue that you are having is very odd. The Firmware updater should not be causing these problems. Do you happen to have another Hydra? On top of submitting an RMA for the Hydras that are in question, if you were to have another Hydra you could try to manually update by means of the SD card or grounding pin 8 on either sockets 3 or 4 and use the updater program to see if you get the same result.

Nothing that is done to the hydra can delete or corrupt the on-chip boot program because it is part of the physical design and is not software.

You do disconnect power, short the pins and while shorting the pins you apply power to the board, right?

@ Aron: to be sure, next time I will try with another machine (an older one, with WinXP) and follow the manual procedure. But the mistery remains…

@ GMod(Errol): Right. I followed the procedure to the letter.

Could this picture be useful to understand the problem? Here we can see the hardware ID of the “unknown device”…

@ andre.marschalek: I also thought the same thing… because I know that translations may generate odd issues !! I will try also with a virtual machine in english language…

Also, is your mashine set up to look for drivers on the Microsoft Updates site?

I think your board is in boot loader mode, but your PC does not have the drivers installed for that mode. And the drivers are not provided by GHI, that install automatically on my PC by downloading from Microsoft, and appears as a GPS or Camera, can’t quite remember, but I remember that it was something odd…