4.2 support is finally here, download now!

This is an old thread. Do not use it please

We finally made it! Here is a package installer with NETMF 4.2 support.

STOP You need Microsoft NETMF 4.2 SDK with this update.

  1. Uninstall all GHI SDKs you may have
  2. Uninstall Microsoft’s .NET Micro Framework 4.1
  3. Download and install NETMF 4.2 (SDK 4.2 RTM QFE1) http://netmf.codeplex.com/releases/view/82448
  4. Download and install this package http://www.ghielectronics.com/downloads/NETMF/Beta/GHI%20NETMF%20v4.2%20and%20.NET%20Gadgeteer%20Package.zip

Important information:

  1. This package still has 4.1 support for EMX (spider/cobra), 4.2 comes in near future but not to worry Microsoft NETMF 4.2 SDK does support 4.1 devices.
  2. Hydra is supported in 4.1 and in 4.2
  3. Cerberus/Cerbuino is supported in 4.2 only. Obviously we will not support 4.1
  4. Spider is supported in 4.1 only so when you make a gadgeteer project, select 4.1 for now.
  5. All modules support 4.1 and 4.2 with the exception of OBD which supports 4.2 only.
  6. Update your device firmware

More info:
There was a lot of changes on gadgeteer structure to support 4.1 and 4.2 simultaneously, thanks Microsoft. We also had to do a lot of work to bring this to you with support for 4.1 and 4.2 giving you the options to select what to use. These numerous changes needs a lot of testing. We have done plenty but it is your turn.

Do NOT use old projects to test. Instead start a new project.

How can you help?
Please install this package and use it. Feedback is welcome.
Remember to check this for timeline (we are right on schedule, maybe early) http://tinyclr.com/forum/1/6212/

You mean 4.2 SDK supports 4.1 devices?

Oh, and:

Do you have some sort of announcement to make?

Whoohoo! Great! Thanks GHI! ;D

Fixed, thanks

Even Gadgeteer for Cerberus? Cool!!! ;D

I assume EM (CANXtra) is not supported in 4.2?

Great news!

:dance: :dance: :dance: :clap: :clap: :clap: :dance: :dance: :dance: :dance:


Since this is the first time I am doing this, I just want to double check. When you say uninstall all the GHI SDKs, does that include the ‘GHI NETMF USB Drivers’. A stupid question I am sure, but since it is not a SDK I just want to make100% sure so I do not end-up having to jig things later.



There is no need to uninstall the drivers. You’ll be fine.

Thank you Steven.

How about Panda II? When can I expect an 4.2 MF support for it.

I perfomed the instructions as mentiond.
I connected up my Cerberus, created a new project, made no changes and when i ran it i received the following message.

“An unhandled exception of type ‘System.NotImplementedException’ occurred in Microsoft.SPOT.TinyCore.dll”

did i not do something correctly ?

What setup? What code? What steps? :slight_smile:

@ GUS - i performed the steps as in your first post here.
I Then started VS, FIle, new project. Selected .NET Gadgeteer (NETMF 4.2), then click ok.
Then i clicked on Program.cs, and then pressed F% for start debugging.

Got the following (see below) in the output window, then a VS popup saying
"An unhandled exception of type ‘System.NotImplementedException’ occurred in Microsoft.SPOT.TinyCore.dll"

Found debugger!

Create TS.

 Loading start at 8036fc8, end 804b620

Assembly: mscorlib ( Microsoft.SPOT.Native ( Microsoft.SPOT.Hardware (
Assembly: Microsoft.SPOT.Graphics ( Microsoft.SPOT.Hardware.SerialPort (
Assembly: Microsoft.SPOT.Net ( System ( Microsoft.SPOT.Hardware.Usb (
Assembly: Microsoft.SPOT.Hardware.PWM ( Deployment Assemblies.

Attaching deployed file.

Assembly: Microsoft.SPOT.IO ( deployed file.

Assembly: GHI.OSHW.Hardware ( deployed file.

Assembly: Gadgeteer ( deployed file.

Assembly: System.Http ( deployed file.

Assembly: Microsoft.SPOT.Net.Security ( deployed file.

Assembly: GHIElectronics.Gadgeteer.FEZCerberus ( deployed file.

Assembly: Microsoft.SPOT.Touch ( deployed file.

Assembly: System.Net.Security ( deployed file.

Assembly: Microsoft.SPOT.TinyCore ( deployed file.

Assembly: GadgeteerApp4 ( deployed file.

Assembly: System.IO (

The debugging target runtime is loading the application assemblies and starting execution.

'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\mscorlib.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Native.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Hardware.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Graphics.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Hardware.SerialPort.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Net.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\System.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Hardware.Usb.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Hardware.PWM.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.IO.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\Assemblies\le\GHI.OSHW.Hardware.dll'
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Gadgeteer\Core\Assemblies\.NET Micro Framework 4.2\le\Gadgeteer.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\System.Http.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Net.Security.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Mainboards\FEZCerberus\NETMF 4.2\le\GHIElectronics.Gadgeteer.FEZCerberus.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.Touch.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\System.Net.Security.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\Microsoft.SPOT.TinyCore.dll', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Users\Jim\Documents\Visual Studio 2010\Projects\GadgeteerApp4\GadgeteerApp4\bin\Debug\le\GadgeteerApp4.exe', Symbols loaded.
'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Assemblies\le\System.IO.dll', Symbols loaded.
A first chance exception of type 'System.NotImplementedException' occurred in Microsoft.SPOT.Native.dll
A first chance exception of type 'System.NotSupportedException' occurred in Microsoft.SPOT.IO.dll
The thread '<No Name>' (0x2) has exited with code 0 (0x0).
Using mainboard GHI Electronics FEZCerberus version 1.1
A first chance exception of type 'System.NotImplementedException' occurred in Microsoft.SPOT.TinyCore.dll
An unhandled exception of type 'System.NotImplementedException' occurred in Microsoft.SPOT.TinyCore.dll

do you know what statement got the exception?

Program program = new Program();

@ jdal - I got the same error when I first installed all the 4.2 stuff, but after I upgraded the firmware on my Cerberus everything worked fine. Try to update the firmware following the instructions here: http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Cerberus

Are all 4.1 projects supposed to work in 4.2 or is it supposed to be required to re-create all solutions. I just installed the 4.2 bits (after uninstalling everything GHI). Now I can’t open the projects I was working on just prior to the install :frowning: I already had NETMF 4.2 installed. I didn’t bother re-installing it.

EDIT: I fixed it. Opening the .csproj files directly in notepad then changing the value of from “v4.1” to “v4.2” and then reloading the projects fixed it.

Where did GTI.SoftwareI2C go?