4.1 to 4.2 Now ToolBox is Empty

I upgraded from 4.1 to 4.2.

When I open an existing project, the toolBox is empty.

How do I fix this?

If you create a new project do you get the same result or is it only in old projects? Also, make sure you keep the toolbox open for a minute or two. I’ve noticed that sometimes it takes a while for the toolbox to populate the first time opened.

Only in old applications.

I see the note in GHI Electronics – Where Hardware Meets Software recommending starting new projects rather than attempting to use existing 4.1 projects.

Also namespace changes, pwm and output compare changes…

That seems to indicate that all (most?) code needs to be re-written.

Maybe this should have been 5.0 rather than 4.2?

You’ll find that you actually have to re-write very little. It won’t take long. Just create a new solution and re-add your files then compile. You may or may not end up with a list of things to fix. Make more posts if you have problems tracking down their equivalents in 4.2.

47 projects


The Microsoft way could certainly be scripted. Although, I have some doubts about it’s success due to other references. I’ve had good success with just going into the project properties and switching to one framework, saving, and then switching back to the other. You might give it a try before you embark on converting 47 projects.

The microsoft way DOES NOT WORK because the changes GHI made to the namespaces!

As I said before, changes that break things in a major way SHOULD be major releases, not minor as in 4.1 to 4.2!

Tom, appreciate the impact you’re feeling. You do need to understand though that the changes in the core netmf from 4.1 to 4.2 aren’t “breaking”, and that the changes to the other component from GHI are moreso; but again, if you don’t have a compelling reason to move to 4.2 then don’t. You can still target 4.1 without uninstalling anything.

Based on the, possibly mistaken, forum post that 4.1 SDK was no longer supported and to use 4.2, I upgraded to .NET 4.2 and SDK 4.2.

Now, when I create a 4.1 project, the toolbox is empty. So, I cannot create a 4.1 project! Nor, can I change an existing project.

So, I am faced with several hours of wasted effort to convert existing projects to 4.2!

If using gadgeteer then 4.2 is the only option. Otherwise you can use 4.1 if you like

This is lame. I have to use 4.1 because I need Wifi (rs21) and I am reading of too many issues and still no solutions for this in 4.2 (and this alone seems pretty irresponsible, given the huge time span). Afraid to upgrade and get off the “unsupported” framework, only to then end up with an unsupported wifi.

We are trying to concentrate on 4.2 but you can use 4.1 if it is good for your needs, by keeping the older SDK I mean.

The support in 4.2 is much different and much better than 4.1 but not as solid just yet.

Gus, you really do rock. I was too harsh with my “irresponsible” comment. The fact is, this is cool stuff, in a market with limited resources. Might I suggest not dropping support for prior frameworks before all the basic functionality (wifi, etc) is working in the new.

I totally look forward to moving onto 4.2. In the meantime, it’s not clear how to get 4.1 Gadgeteer Tools on a new dev machine. With 4.2 + 4.1 (optional) installed form the GHI support site, I see 4.1 as an option to target, but that doesn’t give one a set of 4.1 toolbox tools for Gadgeteer.

.NET Micro Framework – GHI Electronics is the place to pick up an old framework version. The April one is the one you want IIRC.

1 Like