Main Site Documentation

32gb SD card wrong TotalFreeSpace reported


#1

Hi,

FEZ Hydra, G120HDR & FEZ Spider all report wrong free space with 32gb SD card (tried different brands). Everything else works perfectly - writing and reading. Is there anything that can be done about it?

Thanks, Greg


#2

@ Hyperlisk - What is being reported? How wrong is it?


#3

Sometimes it’s ~ 1.5GB (when it’s completely blank), sometimes ~3GB (when filled eg. 10GB). It depends on used space.


#4

I had an issue like this on one of my HCSD cards. A reformat fixed it right up.


#5

I tried formatting with different allocation unit sizes but nothing helped.


#6

Have you tried with a different and/or smaller SD card?


#7

@ Hyperlisk -

Try this


#8

@ Hyperlisk -

We will check.

Just a funny story.
I bought an USB thumb drive which is 2GB, formated and did everything, it still reported 2GB. But when tried to write files on there, it can not be written more than 1G, it meant actual size is 1G. :)))


#9

I’ve heard of this being a problem with some of the cheap Chinese knockoffs. Even worse, I’ve heard of some that report large sizes but in reality they write to a very small flash chip in a circular pattern w/o reporting that they have run out of space. So, you write 512KB and the 513 byte goes back to the #1 spot!


#10

Smaller SD cards (I tested 4GB) work fine but I need 32GB to work.

@ ianlee74: Hahaha that’s funny :slight_smile: You made my day. I’m using genuine Sandisk/Transcend/Kingston cards btw.


#11

I tried the tool. 32GB card still reports (in bytes): Free space: 1837596672 which is ~1.7GB.


#12

@ Hyperlisk - That’s a known limitation of the NETMF file system implementation. It only uses 32 bit integers for file offsets, which causes a limitation to 4 GB.

To remove this restriction, now that would be a great community project! Probably not difficult per se, but it would require extremely careful editing of the sources, and thorough testing.


#13

So I think what Cuno is currently saying to you is that you don’t need to worry - I’d try to write lots of data to the volume and keep checking the available space and check the available space does not get low until such time as the volume is actually getting low on space.


#14

Not really. For our Mountaineer Prime firmware, we explicitly say that SD Cards and USB memory sticks must not be larger than 4 GB.

If you use larger cards, I’d expect integer overflows resulting in randomly appearing errors.


#15

I got it working for G120 using RLP. Now I get perfect free space in bytes - same value as Windows reports!