3 Raptors failed while debugging


I have been having multiple problems with my FEZRaptor’s and attempting to debug a solution with them
The first problem I was having was deploying to the Raptor using VB community 2015. I posted my problem in the thread below.
I used @ glx 's attempted fix and was unable to debug my code after deploying.

I then decided to switch over to VB 2013 and reinstall all the required SDK and Gadgeteer files. I connected my previously working Raptor setup (USB immediately seeing it) to deploy my 2015 solution using VB 2013. As i deployed my solution, a debugging error occurred during the deployment.
I re-attempted to deploy the solution and my computer was unable to find the Raptor anymore. Multiple attempts to find the device were unsuccessful. Suspecting that the USB Client DP was the problem, we used a DMM to measure 3.3v and 5v and found that both read 5V (shorted!). I used a new USB client DP board and found the same short when i hooked it up to my already burned Raptor board(assumption).
A new Raptor was used, along with a new USB Client DP, and the computer finally found the device. I re-deployed had the same error occur. The device became unreachable. the only difference was that 3.3V and 5V were not shorted. Its almost as if my deployment burns out the Raptor.
We have used 3 different USB Client DP’s and burned out 4 different FEZRaptor’s.

Any help would be greatly appreciated!

I don’t think you Raptors are dead, they are just stuck being able to appear to the debugger. Do they return if you hold down LDR0 and LDR1 and then show up in Device manager? This puts them into bootloader mode.

This sounds like your code is causing something, possible a tight loop somewhere or no Thread.Sleep call.

Boot the board into bootloader mode by holding LDR0 and LDR1 and then use FEZCONFIG to erase the application and it see if it now responds.

my #1 ask is please take screenshots of what you see in device manager, and turn sounds on to see if you get the device connected/disconnected sounds when connecting the devices to the PC, and let us know the results. The Raptor should be like any other USB device, you should see an entry of some kind in device manager (it will vary depending on the boot state of the bootloader and the netmf) and you should hear normal connection sound and disconnection sound when you connect/disconnect.

So, I have used FEZConfig with each Raptor but am unable to even see the devices.

Both FEZConfig and Device Manager are unable to see the Raptors after I had deployed my solution. Before deploying my solution to the Raptor, it works fine. It is correctly and immediately identifiable in Device Manager and FEZConfig. Once i deploy the solution in VB2013, the Raptor immediately stops being able to be found. When plugged into the computer, there is an initial sound of it TRYING to connect, and then nothing after. I have looked throughout Device Manage to see if somehow is was being identified as a Serial Port instead of USB, to no avail.

In FEZConfig, I have tried to find the device while in Bootlegger mode by holding LDR0 and LDR1 to reset the device. When hooked up via usb, even pressing the reset switch on the Raptor has no effect (no sound, not found, not identified in DM and Config).

I have one last Raptor that I will be attempting to repeat this process with. When I do, I will post all relevant screenshots. However, there seemed to be no clear indicators as to what happened during the deployment.

Thanks for helping!

your problem is in your code. Before you deploy your solution to the last raptor, step through the process of re-loading the firmware on that device and make sure deploying simple code works.

You have to hold LDR0 LDR1 and then reset the board - you can hold them down and then connect to the PC, and you should see the bootloader device in device manager.

@ Brett - I was able to see the Raptor as a GHI Bootloader Interface. However when I went into FEZConfig, I was unable to communicate with it. What can I do with the non-working Raptor’s at this point?
The first two images are of FEZConfig attempting to connect to the device, as well as Device Manager finding the bootloader interface.

The Final Raptor successfully had new firmware updated and a simple LED program deployed to it. There were no problems deploying a simple program to this Raptor. Should I attempt to re-upload my code to this raptor?

Note, I downloaded VB2013 yesterday (already had 2015). There may have been some error in getting all the correct updates downloaded (not sure). I went ahead and uninstalled everything and freshly installed just VB2013 with all the required updates.

Here is my “Raptor Breaking” code:

using Gadgeteer.Modules.GHIElectronics;
using System;
using System.Collections;
using System.Threading;
using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;
using Microsoft.SPOT.Presentation;
using Microsoft.SPOT.Presentation.Controls;
using Microsoft.SPOT.Presentation.Media;
using Microsoft.SPOT.Presentation.Shapes;
using Microsoft.SPOT.Touch;
using GHI.Pins;
using Microsoft.SPOT.Hardware;

using Gadgeteer.Networking;
using GT = Gadgeteer;
using GTM = Gadgeteer.Modules;

namespace GadgeteerApp2
public partial class Program
void ProgramStarted()

       //GT.Timer timer0 = new GT.Timer(1000); // every second (1000ms)
       //timer0.Tick += Timer0_Tick; ;
        Debug.Print("Program Started");        

        PWM pwm = new PWM(Microsoft.SPOT.Hardware.Cpu.PWMChannel.PWM_7, 1000, .5, false);           
    private void Timer0_Tick(GT.Timer timer)
        GTM.GHIElectronics.TempHumidSI70.Measurement m;
        m = tempHumidSI70.TakeMeasurement();
     //   this.characterDisplay.Print(m.Temperature.ToString("N3"));
     //   this.characterDisplay.SetCursorPosition(1, 0);


I uploaded the code to the fifth Raptor and had the same error occur. The images below show the results from the Output window. The program started to execute, and then encountered an error part way through. Not the same error, but what seems to be similar to as before. The Raptor (working minutes ago) has stopped working and is unable to be found in FEZ Config and Device Manager.

The only way to see it is in Device Manager is as a Bootloader device.

@ Das_BooF -

As Brett said…
You have to hold LDR0 LDR1 and then reset the board -

I have had a similar problem with my raptor a few times. Not sure if you have the same problem as I had but use the Device Manager
and see if you have a serial port showing – GHI Bootloader Interface (Some COM Port Number).

My problem was that the Bootloader serial port would not go away.

The only way I could get my Raptor to work again was to Hold LDR0 LDR1 and then release them and then
rapidly press the reset button many times.

Sounds goofy but it has helped me several times in the past.

Once working I erased the application for a fresh start.

Worth a try…

@ willgeorge -

Great, thank you! I had been doing it correctly. I was holding LDR0 and LDR1, connecting as Bootloader, however when attempting to erase and upload the firmware, It was still unable to find the device.

Problem Solved! - I used your method of multiple attempts resetting the device while trying to find it with FEZConfig and Device Manager and it seemed to finally work on the 3rd or 4th attempt. I had disconnected the board, reloaded as a bootloader, had FEZConfig already open and waiting to find an available Port (-picture shown below), DID NOT RESET THE DEVICE, and immediately(still as bootloader) updated the firmware. This is how I was able to fix 3 non-working raptors.

One Raptor was unable to be fixed though. When I attempted to connect it as a Bootloader (LDR0 and 1 pressed), it found the device as a USB device with an “unknown descriptor fail”. All of a sudden, it seemed to find the device and calls it a “Bossa Program Port(Com 5)”. This port can be found in FEZConfig, however, when I attempt to Update it, it fails as shown in the images below.

@ Das_BooF - For the bad Raptor, follow the steps on https://www.ghielectronics.com/docs/336/g400-bootloader-installation to reload the GHI Bootloader. It looks like it got corrupt or was never present.