Main Site Documentation

2 dead Panda II's


#1

Everthing was going great for the past two months as I developed my application for the Panda II. About two weeks ago I was tweaking the SD card logging code and now my code can’t be deployed to the Panda. I’ve tried to erase the image using MFDeploy but it can’t ping or erase the board. I tried another Panda but as soon as I tried to debug by code on the new board it also became unresponsive.

I’m stopped. How do I at least get access to these boards so that I can erase the code and start over?

Thx…


#2

Can you get into the bootloader interface? Hold down the Loader button while booting and then check your devices for a serial port popping up.

Try and “upgrade” the firmware just to be sure.

If you can’t even talk to the bootloader then there must be something wrong with the USB connection or the chip is really fried.


#3

You could try to reinstall the firmware.


#4

Note that realiser meant “while plugging in the usb cable” not “booting”. So don’t go rebooting your PC while holding the loader button… :slight_smile:


#5

Or try thr firmware updater: http://www.tinyclr.com/forum/12/3529/


#6

I got it fixed. I’m such a newb :-[

Anyways I moved some code to get the baudrate for COM1 to the settings file on the SD card and then for some reason commented the code to gets that setting. That meant that the serial port was set up with a baud rate of 0 and this is what caused the board to essentially lock up and become unresponsive. I could not find any docs that decscribed how to use the loader button.

All is back on track. Thanks for the prompt replys.

Brent…