Main Site Documentation

2 dead hydras


#1

I have 2 new Hydras that worked for a short time and then stopped working. Firmware was initially updated using FEZ Config and both boards ran simple C# LED blinking etc. for a short time before not being found by Visual Studio. The FEZ Config utility recognizes the boards as USB FEZ HYDRA_Gadgeteer and the bottom status bar says “FEZ Hydra_Gadgeteer is connected”. When I Ping it, a message box says “Failure - Device is not connected or not responding”.

I have tried the following:
Uninstalled and re-installed all software and drivers.
On 1 board, I tried a manual firmware install following instructions to short pins 8 and 10 on socket 3. Doing this did not give me a serial port as described, but showed up as an unknown device.

Any thoughts on repairing these boards?

Thanks - Brian


#2

Welcome to the community!

It sounds like you have a very tight loop running and Visual Studio cannot connect. Try to use the Erase option in the FEZ Config utility. If that doesn’t work, try to reinstall the firmware.


#3

I am not in visual studio any more. The Fez Config utility is not able to connect to the module to allow an erase or a firmware update.


#4

I am also having same issue from the last weekend after I’ve downloaded VS2012 update. I could do firmware update for Spider, Cerberus, and Cerbuino Bee but not Hydra.

tried FEZ Config and also manual steps - no luck on my Hydra.

I am on Windows 8 64 Bit version.


#5

Please try the instructions here and use the technique of grounding pin #8 of socket #3 to enter bootloader mode and then try the UpdateFEZHydra.bat command.

https://www.ghielectronics.com/docs/125/firmware-update-fez-hydra


#6

I tried the grounding of pin 8 on socket 3. It resulted in an Unknown Device in ‘Device Manager’. It did not show up as any type of serial device.


#7

What do you see in “Devices & Printers”?


#8

“Devices and Printers” shows an “Unknown Device” under the category of “Unspecified(1)” after turning hydra on with pin 8 and 10 jumped. When starting without the pins jumped, The device is listed as “FEZ Hydra”


#9

Anyway you can plug it to another machine? Windows should get the drivers automatically.


#10

@ brianf - Try to run the GHI SDK again without uninstalling it first and choose the “Repair” option.


#11

@ ianlee74 - windows should find the driver even without the sdk. This is a tough one!


#12

Yes, but… I had a very similar problem last week. I thought that my problem was that I had just not finished the SDK install on my laptop. Running the repair option got me working. Unfortunately, I discovered this problem in the middle of a presentation :frowning: I really think I probably was the cause but if it fixes his problem then I’ll be ready to say there’s something wrong with the installer of the last SDK under some condition.


#13

I am not able to ping Hydra from MFDeploy

From FEZ Config it shows connected initially on plugging it and on ping it shows as in screenshot below


#14

I’m curious about how you renamed the device. That’s a longer name than I’ve ever tried. Has it worked since you renamed it? Can you rename it back to the factory name of “FEZ Hydra_FEZ Hydra”? Perhaps you’ve broken some rule. It definitely looks like it should be working.


#15

yeah I’d be suss about the rename too. Can you try it without renaming it?


#16

Update:
I did a “Repair” of the installation as per ianlee’s coment. Nothing changed.

I installed an sd card with boot.bin as described in the Firmware Update instructions. Now the cleared hydra shows up in the device manager as an “Unknown device”. It does not show up as a serial device, and it has no driver assigned it.


#17

Renaming of Name happened on the first try last sunday. it worked updating the firmware, but failed at last moment with the same message - Device not connected.

after that I tried updating FEZ Config. It is showing the same message as per last screenshot.

I tried connecting extender module and connecting wire for Socket#3 8 to 10 pin for 5secs. no luck.

running batch required com# port no, I can’t find it.


#18

I also tried with SD 2 GB with boot.bin file with SD card module.


#19

BTW, I used MicroSD card with MicroSD Adapter for this purpose - not SD card.


#20

when the device starts with the pins linked, it should appear as a COM port. Can you tell us what happened in that scenario, what you could see in device manager?