Main Site Documentation

Xbee woes (Sparkfun regulated explorer board)


#1

I have recently acquired 2 Xbee 900 Pros, 1 Xbee explorer (usb) and regulated xbee explorer (UART).

I have reason to believe the regulated xbee explorer may be faulty, but I just want to double check with you guys.

Here’s what I’ve done:

  • used X-CTU to make sure the firmware on both xbees are up to date, and I reset them to factory defaults.

Test 1:


  1. Computer <-> USB cable <-> Xbee explorer <-> Xbee 900
  2. Computer <-> UART USB cable (MAX232) <-> regulated xbee explorer <-> Xbee 900

I ran X-CTU and realterm, each connecting to an Xbee.
Typing from USB Xbee explorer -> regulated xbee explorer = Text correct
Typing from regulated xbee explorer -> USB Xbee explorer = NULL for each CHAR

I swapped the Xbees to the other explorer, but I still go the same result, so this rules out one of the Xbees being faulty.


Test 2 (See attached image):


  1. Computer <-> USB cable <-> Xbee explorer <-> Xbee 900
  2. GND -> Both Xbee GND pins, 5V -> Xbee 5v pin, Xbee DOUT connected to Xbee DIN (loopback)

Only ran X-CTU this time and connected to the USB explorer.
When I typed I got NULL back for every character. (See X-CTU image below)


Additional information: The USB explorer shows the CTS light on in the term program, when the reg explorer is connected by the UART cable CTS light is not on in the Term program.

Can anyone suggest any other tests?
Or is the regulated explorer board faulty?


#2

Test 1:

What is the BPS on UART USB cable(MAX232)?


#3

Yes, most likely a BPS problem.


#4

You have probably seen this at SparkFun, but there might be an issue with the 900 and the explorer;

http://www.sparkfun.com/commerce/product_info.php?products_id=9099


#5

Hi Geir, You were right. As soon as I bypassed the diode it all worked fine.

Looking at the schematic and the board, it seems the diode is facing the wrong way.

Also, I’m not sure if i’d like a diode there, as my signal IN would have a voltage drop of 0.4V across the diode.

Thanks for all the replies.


#6

Wow that was a tricky one :o Sorry that I did not come up with this, I really thought it was a BPS problem :-[