Main Site Documentation

Wrt Support for NETMF 4.1 and VS2010 [locked]


#1

wrt latest sdk…

[quote]=======================================
Not sure how or upgrade?

  1. Uninstall all GHI NETMF SDKs, Microsoft NETMF SDK, Visual studio 2008
  2. Visit the downloads page and follow the installation steps http://www.tinyclr.com/dl/
  3. The FEZ tutorial should be a great help if you are lost.
    [/quote]

OK I can agree with uninstall GHI SDK and even NETMF SDK, but to uninstall vs2008 is a little harsh, some people do desktop development etc and need vs2008,
I havent had any problems so maybe the uninstall vs2008 is only required as a last resort??


#2

You do not have to uninstall VS2008. We only say this to eliminate any issues from beginners. You actually can keep GHI SDK 4.0 and 4.1 on the PC and use both!

So, the instructions are general but you can keep VS2008 if you know what you are doing.


#3

HiGuys
Look familiar? I have been frustrate with this error and was not able to get it fixed. I installed Vs2010 yesterday then ran into this issue, after spent a lot of time removed older version of netfm and install new version of netfm, it worked, today i try again it didn’t. I am very frustrated.

Reinstalled VS, NetFM, GHI NETFM, USB driver.
Replace Microsoft.SPOT.Debugger.CorDebug.dll …nothing help.

Thanks!


#4

See the big yellow ALERT to the right? of this website :slight_smile:

Make sure you install all new 4.1 then update the firmware


#5

Gus,
Ok so that was what happen, but Where do I download the firmware for Mini, I dont see any link on Download page?

Thanks!


#6

I think I found it, but It would save us time and frustration the video mentions where the new formware is located on the system and how it got there (from which installation package).

It will be good if this procedure be documented the firmare update page.

Thanks!

updated: forgot to post the location
C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\USBizi\Firmware


#7

The 4.1 firmware is a single download. Please download from

http://www.ghielectronics.com/downloads/NETMF/GHI%20NETMF%20v4.1%20SDK.zip

You have to use the USBizi firmware as FEZ Mini is built on USBizi

HTH


#8

Rajesh
i installed that yesterday, now I just need to update firmware using file installed by that package
C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\USBizi\Firmware\USBizi_CLR.GHI

Still run into issue, after updated firmware, ping failed.
There is some issue, check my version it still say 1.07

Edited: looks good
Thanks!


#9

I do not think we can make this any clearer! The download page has the downloads that you need in order and then the BIG alert on the right reminds you of the update…the videos also show you how to update the video.

If that is not enough, go through the tutorial step-by-step and it talks about the firmware update

Still not enough? The ebook has a section just for firmware/assembly matching that explains that you need to update the firmware!

I really do not think we can make this any clearer :frowning:


#10

The instruction video is great. just that I got stuck at the segment where demonstrator pick up the file for transfering to the device, the instructor shows the firmware file but didn’t really show where that file is located so I was wondering if the file reside in the system or it is to be downloaded from GHI or from goole :-). Maybe it’s just me…who expects this process to be Freaking Easy, but it wasn’t for me since I was not too bright. anyhow, just one man’s opinion.

Thanks!


#11

I see, we will look into it and try to make this more clear


#12

Hey Gus, i’d probably agree, it’s time to have a single video that goes thru setup/upgrade JUST for VS2010/netmf4.1 since there have been many changes since the original vids were made - the “common” firmware being one of the big changes that people obviously can get tripped up on


#13

I updated the video annotation to include a link to where the firmware is