Working G120 w/Glide application now stuck on debug output: "Cannot find any entrypoint!"

I have a G120 application in a custom PCB design that I have had successfully working using a 4.3" New Haven display touchscreen that now will not run. It gets stuck in the debugger with “Cannot find any entrypoint!”. The issue has happened to me at least 4 times now, and the previous times it has occurred I have been able to start a new project, and bring in all my code files and resources from the old project, rebuild the new project and get up and going again. This time, however, I cannot even get that to work.

It seems like the problem occurs when I am doing some adding/deleting of resources in my project. I deleted a jpeg resource image, and replaced it with a bmp image in windows explorer… when I returned to the resources viewer in visual studio for the project, it showed that the old jpeg file was missing, i removed it, and then added the new bmp file. Then when I went to build and debug the solution, I now get the “Cannot find any entrypoint!”.

I have tried everything I can think of, cleaning both the projects and solution, restarting VIsual Studio (using 2012), restarting whole computer, starting a new project and making sure all resources, entry points, and references are up to date. And nothing seems to help. Has anyone had the same problem lately and been able to get it resolved? I assume this is a problem with the resources and Glide and that’s why I haven’t seen many other posts exhibiting this issue.

I am using Visual Studio 2012, G120 module, and GHI SDK version

Here is the Debug output window:
Found debugger!

Create TS.

Loading start at a0e6945c, end a0e988f0

Assembly: mscorlib ( Assembly: Microsoft.SPOT.Native ( Assembly: Microsoft.SPOT.Security.PKCS11 (4.3
.1.0) Assembly: System.Security ( Assembly: Microsoft.SPOT.Hardware (
Assembly: Microsoft.SPOT.Graphics ( Assembly: Microsoft.SPOT.TinyCore (
Assembly: Microsoft.SPOT.IO ( Assembly: System.IO ( Assembly: Microsoft.SPOT.Hardware.Usb (
Assembly: Microsoft.SPOT.Hardware.SerialPort ( Assembly: Microsoft.SPOT.Touch (
Assembly: Microsoft.SPOT.Ink ( Assembly: Microsoft.SPOT.Hardware.PWM (
Loading Deployment Assemblies.

Attaching deployed file.

Assembly: Microsoft.SPOT.Net ( Attaching deployed file.

Assembly: GHI.Hardware ( Resolving.

GC: 1msec 332772 bytes used, 7006896 bytes available

Type 0F (STRING ): 24 bytes

Type 15 (FREEBLOCK ): 7006896 bytes

Type 17 (ASSEMBLY ): 24924 bytes

Type 1E (BINARY_BLOB_HEAD ): 307752 bytes

Type 34 (APPDOMAIN_HEAD ): 72 bytes

GC: performing heap compaction…

The debugging target runtime is loading the application assemblies and starting execution.

Cannot find any entrypoint!


Waiting for debug commands…

‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\mscorlib.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Native.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Security.PKCS11.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.Security.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Graphics.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.TinyCore.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.IO.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.IO.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.Usb.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.SerialPort.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Touch.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Ink.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.PWM.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Net.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Libraries\le\GHI.Hardware.dll’
The program ‘[0x8] Micro Framework application: Managed’ has exited with code 0 (0x0).

When things get very strange like that (extremely rarely for me) I start a brand new project in VS and see what results I can get. If still no luck, I reload the device firmware using FEZ Config. Note that all our testing is using VS2013.

I may be forced to try using VS2013. I have already tried like you said and re-loaded the firmware using FEZ config a couple of times at various steps in my “cleaning” and “rebuilding” of the solution (along with restarting VS)

Thats what I get usually on the first start of Debugger each day.
Just try again. It usually works the 2nd time for me and then never happens again until next day.

OK, so I got it working again and thought I would let others know how I was able to fix it. It seemed to have something to do with the last bitmap image I added as a reference to the project. During the build, the output window indicated I still had plenty of flash free, but apparently that image put me over some sort of limit that the compiler/VS/G120 didn’t like. I removed the image and it started working again. So if you get this problem, check to see how large your solution is and possibly that has something to do with it.

If you enable some verbose compiler options you can often find these things.