Main Site Documentation

Wiring a Nordic nRF24L01 module to a Gadgeteer socket


#1

Hi all. I need someone else’s opinion on something that just doesn’t make sense to me. I am trying to wire up some nRF24L01 modules to gadeteer sockets. My reference is the following page:

But it looks to me as if the diagram on that page is wrong. For example it shows Pin 2 as GND, But GND on Gadgeteer sockets is on pin 10 as far as I know.

Has anybody used that diagram on that page to wire up a nRF24L01 module to a gadgeteer socket and did you also notice the diagram is wrong, or am I just mistaken?


#2

The diagram is for the UEXT socket not the Gadgeteer sockets. I am not sure were they UEXT sockets were used, but I guess it was a socket used on the earlier GHI boards. Before our time I guess.


#3

the UEXT connector it talks about is NOT a Gadgeteer socket, so you should ignore everything related to Fez on that. Use the Gadgeteer socket info https://www.ghielectronics.com/docs/120/gadgeteer-sockets to pick what socket you’re going to use


#4

wow, many replies while typing :slight_smile: UEXT sockets were on Fez Domino and others, and used a standard 0.1" header size.


#5

Thanks for all the quick replies and advice. It makes a lot more sense know that I know that was not a Gadgeteer socket.


#6

In case anyone else is interested, I also found another page with a lot more details about how to wire it up to a Gadgeteer socket. The wiring diagram on this page looks almost the same as I wired it up anyway, except for one little difference which I think was a mistake on their page: http://technicalstuffhopefullyuseful.blogspot.dk/2013/01/rf-wireless-communication-with-net.html.

The mistake I’m referring to is that it looks to me that the labels for wired 6 and 7 was accidentally swopped on a photograph with labels on that page. (MOSI & CSN).

However, even after wiring them correctly as I think it ought to be, I’m still not able to establish a communications link yet.

Do anyone know of a module currently sold by anyone that uses the nRF24L01 chip? I saw Justin’s RFPipe module, but can’t tell if its Bluetooth or something else. The thing is I bought a number of the modules and would like to get them working.


#7

Here is a snapshot of the wiring for Gadgeteer and a panda…
https://www.ghielectronics.com/community/forum/topic?id=5460&page=10#msg67860

See the pictures in my posts under @ Jay Jay post #95


#8

Thanks Jay Jay. It was interesting to read through that entire post. However, I’m still not having much luck to get it to work on my side. I have double checked my wiring several times and used both Gus and Graln’s codeshare examplss. But still cannot get it to work. And since you and several others have successfully got this to work, I can only suspect that the problem still lies with the way I wired it up. I will re-check it all once more tomorrow, but right now I am just too tired after struggling with this all day long.


#9

Your are welcome,
Please take a picture of your setup and post it…

Also make sure the baud rate speed matches on both modules…
Make sure address matches…
Make sure that the string name of the module is 5 char long, like PANDA, SPIDE, CERBE, And so on…


#10

@ Jay Jay - Hmm, I just accidentally deleted my entire long reply. Anyway, what I wanted to say is that I do not think a picture of my setup will help much. I used very fine mod wire and you can hardly see how I wired it up.

But the following as an attempt to show how I wired it up:



3----IRQ----| 8 | 7 |----MISO----8
7----MOSI---| 6 | 5 |----SCK-----9
6----CSN----| 4 | 3 |----CE------4
1----VCC----| 2 | 1 |----GND-----10 

When I run the code (almost exactly the same as your example, I get “Send failed” messages as shown in my debug extract below:

Using mainboard GHI Electronics FEZCerberus version 1.1
I am SPIDE
Program Started
Send failed
Send failed
Send failed
Send failed


#11

@ Kiwisaner, do you have access to a logic analyser? Or perhaps even a bus pirate?

Also, are you using a breakout module to jumper the wires between the module and the socket? Perhaps your wiring isn’t making contact? (and finally, I assume your diagram below is Gadgeteer pin numbers on the outside, and Nordic header on the inside).


#12

[quote=“Brett”]
@ Kiwisaner, do you have access to a logic analyser? Or perhaps even a bus pirate? [/quote]

Unfortunately not. But I do have a scope. I will attempt again tomorrow night to give this another go. Maybe I just need to rewire two new Nordic modules from scratch as I’ve modified the existing ones so many times they are a bit of mess by now.

[quote]
Also, are you using a breakout module to jumper the wires between the module and the socket? Perhaps your wiring isn’t making contact? [/quote]

I use a breakout connecter from Gadgeteer and soldered the wires to a socket into which the Nordic module plugs into.

Yup. (Sorry, I should have mentioned it). Some of the diagrams I looked at labelled the Nordic module differently. But I think my numbering as shown above corresponds with the datasheet itself. That is why my numbering looks different.


#13

I assume the Nordic device has a standard 0.1" header on it (same as breakout module). You could do yourself a favour and buy some 0.1" female header strips, and some breadboard male-male or male-female wires, and wire them up that way, saves the soldering iron if you screw up the wiring :slight_smile:

If you have a digital scope that can decode serial, you might get some insights there…


#14

Maybe it’s wired other way around (Nordic side) eg. pin1 is irq/miso?

EDIT: Scratch that. It’s allright. http://www.seeedstudio.com/document/pics/Interface.jpg


#15

@ KiwiSaner Are you using a Spider or Cerberus? And which socket?


#16

@ dapug - I was using Cerberus boards and socket 6. Have you managed to get it to work? I have not done much more on this as I’ve been busy with something more urgent, but quite keen to get back to it again.


#17

@ KiwiSaner I’ll be trying this out this weekend. Still confused as to how two different sources are wiring it two different ways…

Jay Jay’s post
https://www.ghielectronics.com/community/forum/topic?id=5460&page=10#msg67851

harleydk’s blog (pins 4 and 6 are swapped compared to Jay Jays)
http://technicalstuffhopefullyuseful.blogspot.dk/2013/01/rf-wireless-communication-with-net.html

Also, socket 5 should work in addition to 6, I think. It is SPI (type “S”). I’m thinking I might just try and get two nRF24L01 devices on the same Cerberus to talk as a hello-world, quicker to debug all at once.


#18

FAIL

I’m now at a loss, similar boat: “Send Failed”

And I am way over my head on this driver, no idea how to debug it. in the “status” object, I see DataReady is always false and ResendLimitReached is always true, DataPipe is 7.

Wiring is verified. All I did was hook a single module up to socket 6 on a Cerberus, compiled the Nordic lib to v4.2, use the sample hello-world that Jay Jay supplied… and I get nothin.

I wonder, is there something bad about netmf or gadgeteer v4.2? I don’t want to revert to v4.1. Any of you guru’s out there, I’d love to hear some ideas on what I could check for. How to do some tests or something to see what is working, what isn’t. I’d love to revive interest in this module in the community, given its insanely low cost.


#19

@ dapug -

[quote]harleydk’s blog (pins 4 and 6 are swapped compared to Jay Jays)
[/quote]

Glad you also spotted this. I also noticed the same thing and found it just as confusing. I suspect harleydk perhaps labelled that one wire wrong in his picture.

I agree. I wish I could at least just confirm first that my RF24L01 modules are working correctly and that my wiring is definitely correct. I found some good Arduino and PIC sample code for the RF24L01. I’m considering to first get it working on some other platform so I at least have some kind of reference working project. Please let me know if you get something right… I will do the same.


#20

FYI: I posted a message on the codeplex project pretty much offering cash to update the nRF24L01+ driver to actually work again:

It’s worth it to me to either update this driver, or find some other low cost, simple wireless option. Sub $5 per module/component, or more depending on features, range, etc.

I don’t need all the fancy mesh abilities of xbee, just a simple, low cost device to send and receive messages to do some Pub/Sub.