Main Site Documentation

Windows7 almost made me go nuts!


As you guys probably know, we had a web server demo running on FEZ Panda at maker faire. We had a little problem with the demo where the server “seem” to hang for 5 seconds. I called the GHI office to talk to the guys for a fix but they assured me that they tested it and all went perfectly!!

… we ended up with a long argument on where the hanging is coming from…we couldn’t solve it over the phone. I honestly blamed it on the beta release…I was wrong, read more!

So, we finally got a chance to try this at the office, it worked PERFECTLY! :wall: I couldn’t believe my eyes so I took the demo to my laptop (same one used at faire) and I was seeing the 5 second delay again. Good thing I saw that or I was going to go crazy :slight_smile:

Running wireshark for few seconds showed us exactly where the error is :clap:

So what was the error? Well, on windows7 and only windows7, if you set a default gateway then windows will keep looking for that IP (ARP requests) in which will block the network interface for 5 seconds!!! I removed the default gateway and it started working perfectly. I went back to a windows vista machine but everything worked just fine on vista even if you had a default gateway.

It if my fault that default gateway shouldn’t be set since I do not have a gateway but at the same time, adding an IP for a non-existing gateway shouldn’t block the network interface.

Lesson learned. Hopefully you have learned something from this and you would not have similar problems in future.


It is a simple rule:
If you don’t have a gateway on your network, then you are not supposed to set a fake not existed IP as a default gateway in your network interface settings. :wink: