Main Site Documentation

Windows Vista and CDC VCOM Driver


#1

Today I tried to programm a sample with a virtual com port. Windows prompted me to install the driver. So I downloaded the driver, but Windows didn’t accept it. I tried both - the one without debugging and the one with debugging - but no difference, Windows Vista refused to install the driver.
I found another thread here about this topic, but unfortunately not the solution for the problem. On a Win XP PC it works, but I have to solve it also on a Windows Vista PC.
Can somebody help me?


#2

how did it refuse the installation? were you using an administrator account?


#3

Thank you for your prompt reply. It won’t do the installation - an error messace occurs, that the correct driver cannot be found.
Yes I’m using an administrator account. With the same account I’m able to install the driver for the CDC with Debugging.


#4

In your first post you said you could not install either CDC driver, but in your last post you said you were able to install CDC with debugging?

You said the driver could not be found. When the OS tells you it can not locate the driver, you should then have the option to specify the location of the driver. When you point at the directory with the driver it still tells you it can not find it?

Is this where you downloaded the driver?

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/GHI_NETMF_Interface_with_CDC.zip


#5

In my first post I refered to the installation of the driver for the normal CDC (without debugging) - no driver worked. After posting that, I tried to use CDC with debugging in my programm and then it was possible to install the driver.
But using normal CDC driver installation was necessary again and failed. Also specifiying the location doesn’t help. In the secified folder the only file is the “CDC_Driver.inf” but Windows refuses and told me that this is not the right driver.

Yes I have the driver from this source.


#6

There are two .inf files in the download. Have you tried to use both when requested to load the driver?


#7

yes - i tried both, but no one worked.
with windows xp everything works fine, only vista is making problems.