WiFi_RS21, Unable to enable WiFi module

I’m trying to get the WiFi_RS21 module to connect to an open network.

I’ve tried the 4.2 firmware but I am unable to add it to the designer view.

Now I have downgraded the firmware to and i’m also using the 4.1 SDK.
I have managed to add the module to the designer view but the program doesn’t even get to the ProgramStart function.

I get the errors:

An unhandled exception of type 'System.ApplicationException' occurred in GTM.GHIElectronics.WiFi_RS21.dll

Additional information: Unable to enable WiFi module.

How do I correctly add the wifi module and use it?

Welcome to forum.

First, the WiFi module is not supported under 4.2 yet. Should be out shortly.

The 4.1 exception sounds like the module was not plugged into the right socket?

The other problem might be that you have a 4.2 project not a 4.1 project?

I have the correct project versions. I created a new project just to test it.

Big welcome to the forum by the way - I only just noticved these are your first posts here !

ok, that’s great that you’ve confirmed that the project properties is 4.1.

The other issue that often comes up with the WiFi module is power. We have seen at least one other case where the module would appear to work and then when it went to connect to the access point, it would reset. That is different to your scenario, granted, but can you tell us how your mainboard and module is being powered?

Also given your newness to the forum, can you tell us if this has ever worked, or if you’ve just got your mainboard and wifi module?

I’ve never actually seen the module work. I recently got it.
Its powered via usb to the usbClientDP.

and your DP module is powered just over USB, or with an external power source? (if external, what are the current specs on that module?)

I’m assuming you have a Spider? And you did check the socket like Mike suggested earlier? I don’t have one of these to actually test on so I am not going to be able to help out much more I’m afraid.

I checked the socket.
Its just powered via the USB cable.
It is indeed a spider.

This should help for now GHI Electronics – Where Hardware Meets Software