Main Site Documentation

Where is FEZ Config? - How do I update Spider using new FEZ Config


#1

Hi,

I am trying to update my Hydra and Spider to 4.3 but can’t seem to find Fez Config anywhere.

All of the support pages say it comes with the Gadgeteer installation but that doesn’t seem to be the case for me.

I have downloaded the firmware updaters zip which contains the old Spider updater etc. (but this can’t seem to find my spider when I put it into bootloader mode…)

I’ve been away from Gadgeteer for a while (missed 4.3 and VS2012 updates) so could someone please help me by stepping me through how to update my Hydra and Spider to 4.3?

Thanks for your time,

Poncho


#2

Thank you for the quick reply, I’ve downloaded it now but it doesn’t seem to think that there are any devices attached.

I have my Spider in bootloader mode (switches 2, 3,4 are on).

Device Manager sees it as “GHI Boot Loader Interface”, any ideas why the updater can’t see it?

Thanks.


#3

Ah okay, am I using the “Updater” tab of Fez Config, which just seems to be the legacy spider updater repackaged? Or am I using the Deployment tab?


#4

The Spider updater in the “Updater” tab is the same as the legacy updater and is telling me to put the switchers into Loader mode (switches 2,3,4 ON) like with the old updater - but it still thinks the device isn’t connected.

I’ve tried two spiders now so I don’t think it is the hardware.


#5

I have done this many times. I have tried it with the Loader switches on, with all the switches off (Default), Device manager sees it as a GHI Boot Loader Interface (COMxx) as the updater wants.

Although there is a littler warning triangle - which says:

[quote]This device cannot start. (Code 10)

A request for the USB configuration descriptor failed.[/quote]

Which I assume is the problem, I have performed “Uninstall Driver” and then “Update Driver” on the Unknown Device choosing GHI Electronics -> GHI Boot Loader Interface from the list, I still get the warning triangle.

I have also tried uninstalling everything to do with netmf and gadgeteer and reinstalling it and I’m still getting this problem.

Any other ideas?


#6

Sorry in those previous messages I meant switches 1,2,3 ON for Loader mode.


#7

Yes I’ve done this.

All I have is a spider attached to a USB power module that is connected to my laptop.

It is the only USB device attached.

I have put it in Default mode and Fez Config sees it as an EMX Gadgeteer device. I can ping it and ask it for Device Capabilities and this works fine.

If I go to the Updater tab and click Spider it starts the Spider updater (which looks exactly like the old updater for 4.1/4.2 etc.) and it asks me to put it into Loader mode.

I put it into loader mode (switches 1,2,3 ON) and in Device Manager it comes up under Ports (COM & LPT) as “GHI Boot Loader Interface (COM25)” but it has a warning triangle on the icon.

If I go to Properties then in “device status” it says: This device cannot start. (Code 10). A request for the USB configuration descriptor failed.

Which makes it look like the Boot Loader driver is broken in some way…has anyone else had this problem and if so how did you fix it?


#8

Oh also, I’m on Windows 8 so could this be the problem with the driver?

Thanks.


#9

Thanks for the help but I’ve already done this twice. My cerberus updated fine its just the Spider so could it be something to do with the driver not being compatible with Windows 8?


#10

Hmm okay, I’ll try uninstalling it all and reinstalling it again like you say and report back.


#11

Okay I uninstalled everything.

Restarted.

Reinstalled MF and Gadgeteer Package.

Tried Spider in all the different USB ports I have.

Still got the warning triangle on GHI Boot Loader Interface.

Still doesn’t find the device in Fez Config or the Legacy SpiderUpdater.exe

Any ideas?


#12

This is an ancient version of FEZ Config. The newest is 0.1.3, but it’s nowhere to be found on the website…


#13

The Way Back Machine found it!

https://www.ghielectronics.com/downloads/bin/FEZ_Config_v013.zip


#14

Hah nice.

I just tried using that to update my Hydra but now I think I’ve bricked my Hydra, it’s just always in tinybootloader mode - Well device manager sees it as a “GPS Camera Detect”.

After the updater finished “Device Capabilities” said it was now 4.2 (yay!) but then after disconnecting and reconnecting it, it just appears as the com port and I don’t know what to do. I tried re-flashing it by doing the cmd line tinybootloader updating that is described here: https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra#1183 but that just comes back with a connection error every time.

Have I bricked my Hydra?

(And why is updating anything except the Cerberus to 4.2 so hard?!)


#15

GPS Camera Detect means it’s going into bootloader mode, so you need to get out of that. Have you done the manual steps to update firmware?

Personally, I have no trouble with firmware. I don’t bother with the fancy tools, just go from first principles and use the manual tools, like I did when I got my first board (my Fez Domino which might have finally succumbed to damage :frowning: )