Main Site Documentation

Weird Error on Mass Production


#1

Hi Guys.

Some months ago, we developed 3 new iot products based on G80 processor.

We had no problems with prototypes, and with minor changes we arranged a small production which was also successful.

Now we arranged a larger production (200 pieces), and we can´t deploy the firmware to 80 of them (40% aprox).

The weird part is that we can upload Config.ghi and Firmware.ghi smoothly, but when we try to deploy hex file via FezConfig 40% of them fails (Failure: Device is not connected or not Responding).

We can even re-enter in “GHI Bootloader Interface” mode, and upload ghi files without problems, but the failure rate in deploying hex files is too high.

We have tried this in 2 PCs, Windows 7 and Windows 10, but results are the same.

Have somebody experienced this issue before?

Thanks in advance for your help.

Regards.
Mauricio.


#2

Has the design changed at all between small and mass production?


#3

I wonder if the reflowing temp profile was too high.


#4

Hi Justin.

Thanks for your Reply.

No changes since small production.

Regards


#5

I don`t think it´s temperature related.

You can boot products in Bootload mode via LDR pins and stay there all day if you want. So we think there are no problems in G80, power supply, oscilator and usb connections.

In fact, if you reboot in normal mode, device is discovered by Windows as G80. The problem is 40% of them wont load hex firmware with Fez Config, and of course wont run final application.

Thanks for your Reply.


#6

What about using MFDeploy to load the app?


#7

Hi Justin.

Thanks for your suggestion, but results are the same with MFDeploy and Fez Config.

Regards


#8

Hi Guys.

Problem has been Solved.

We had a lot of capacitors (RTC 18 pF Caps) out of specs. That was blocking the firmware because it write RTC at start up.

Thanks all for your ideas.


#9

@malvarezdel, Can you shed more light on “out of specs”. What were the tolerances of the caps and who was the manufacturer?