Main Site Documentation



The new class for handling Watchdog on the mf 4.0 is supported by fez sdk?


it is supported or will be in next release coming this month



How are things proceding with the watchdog?

I have just converted an USBizi project from framework 3 -> 4.

Everything ok, but I need the watchdog functionality.

Another thing is the systemmanager.reboot functionality, this is missing as well, what am I to do here ?

Kind regards



Things a quite changing in 4.0, to better of course. Current release is still incomplete but will be finished by the end of this month. If you look at release notes, you see what features we will be adding soon.


Hi again

Thank you for answering so quikly.

As mentioned earlier i am converting a project from 3.0 to 4.0.

I will await the reboot and the watchdog functionality.

A more serious matter is the UART3 (COM4) has stopped working in 4.0 correctly.

SerialPort SP1 = new SerialPort(“COM4”, 9600, Parity.None, 8, StopBits.One);

The HW is well tested with 3.0 for more than a month. Have you made changes here ?

Kind regards



What do you mean by “not working”? Can’t send? can’t receive? exception?

4.0 is all new so we have made changes everywhere!


Hi again

On my oscilloscope I can see that it transmits. But the device that normally replies, doesn’t reply now.

I have several HW setups, most of them running framework 3.0, when I switch over to these there is no problem. My device replies.

On my scope i can see a differens also see a differens. It looks like the UART3 TX signal is low for a longer periode than the working TX signal.

My guess is that the UART3 register is not correct configuered when serialport is instantiated,

I hope you can help me.

Kind regards



We did change the timing on UART to lower power consumption. Maybe 9600 baudrate is off? Can you measure the bit time to see if it is 9600? We will do the same on our end. Thanks for helping us to resolve this.

Maybe your device is off 9600?


Thanks for diggin in.......we have about 15 USBizi dev.boards with special made addon PCB that we are to use for some field testing at the end of this month and I had an ambition to have our datalogger code based on 4.0.

I am sure that my device is running 9600 Baud.

This is also proved by the fact that I can switch over to the framework 3.0 boards and communicate with the device without any problems.

So I am affraid that it is the 4.0 that doesn't function well.

Kind regards



This is very strange because the values are not more perfect than they were on 3.0. Maybe your device have the same error on baud rate and so 3.0 worked fine for that. I have put in a request to look into this.

Did you measure the baud rate? Maybe the error is not in the baud rate? Did you scope your device and verified that it didn’t respond? Did you check the data going into your device?

Any info you can provide will help in finding the source of the error


We found the problem, 9600 baud is not correct but other baud rates are fine. We will be releasing an SDK refresh soon


Thanks !

Looking forward to the release. I hope you can find the time for this release soon.

It is a pleasure working with your products.

Kind regards



Hi again

I might not seem to have a lot of pations :slight_smile: but I am getting some heat here.

Can you please give me an indication when

this firmware will be released ? will the reboot and the watchdog functionality be inclueded aswell.

Kind regards



The release should come tomorrow and will only be a refresh of the current SDK to fix couple minor issues and update the documentation. Not sure if watchdog and reboot will be there…I guess we will find out tomorrow :wink:


Thanks !

kind regards