Main Site Documentation

Waiting expectantly for Fezzer update


#1

Hey, just an hour to go till the anticipated Fezzer update might be available! (And, waiting because I have code I want to post. :))


#2

Thank you very much for waiting. The website is very new as you know and there is a lot of work that needs to be done. It will come together we promise you :slight_smile: We only need a bit of time.


#3

hmm ok well still not letting me submit code… any chance we will have it back for the weekend? I have about 10 more sensor drivers to upload!


#4

It will be available tonight hopefully. Changes are being done to both the form and backend.


#5

[quote]Form is currently disabled. It will be back October 29th at 5 PM EST.
It’s taken a lot of time to make sure things are working properly. I’m sure you want to use something that has minimal bugs right?
Tomorrow I will continue to thoroughly test and go live by 5 PM EST or sooner.[/quote]

This makes me a sad sad panda :frowning: What happened to having a dev version and a live version - testing on dev then pushing out to live?

I like that tag filtering is working now though - good work!


#6

Hey Mark

I looked at some of your drivers and feel that the classes for something like LM50, LM60, LM61 can be rolled into one, unless there are major differences between them.

May be the constructor can take a device type that is declared as an enumeration ?

LMTemperatureSensor lts = new LMTemperatureSensor(LMTemperatureSensor.LM60);

My .02 cents is to keep things simple manageble. If you or someone else had to change or enhance the functionality, there will be less code to look at.

**I had to edit because I had used ? ? ? and that was a ‘huh’


#7

I didn’t want excess code in the fezzer samples, typically people would just use one sensor in a project so would only need the one class.

I have something similar to what you’ve shown for a library i’m building (that will not be on fezzer)


#8

Mark, is there any difference in the code between the LM19 and the LM20 drivers? I did a visual compare and could not find it. Other than the name of the class and some white space.


#9

Fezzer is online.


#10

Can no longer edit:

[quote]Remote server or file not found

You tried to access the address http://www.fezzer.com/account/project/124/, which is currently unavailable. Please make sure that the web address (URL) is correctly spelled and punctuated, then try reloading the page.[/quote]


#11

In addition to not being able to edit (which is a big priority for me as i have some typos i need to fix in code)

http://www.fezzer.com/project/134/rohm---bd1020hfv-temperature-sensor/
An exception was thrown when submitting code (i’m guessing) because this is mostly empty, and Opera gave me a page could not be reached error when submitting. Please delete this item.

I added a new tag “analog” as well as specifying code, usage example, and image. No video was linked.


#12

Mark. Thanks for the details. I had the same issue simulating your post. The issue was with creating the new tag. Seems like Opera just likes to fail out rather than continue like the other browsers. Anyway, you should be able to edit your contributions and create new tags without issue.


#13

The current home page for fezzer, which displays recently added contributions, might be enhanced if rather than displaying the current format, a table be displayed with each recent contribution as a single text line containing the title. Clicking the title would go to the full contribution page.


#14

Hmm, I just submitted a bit of code to FEZZer and I didn’t appear to get any points. Is that right?


#15

Ok, well, at this point, it shows that I got my points sometimes after I submit my code. Also , it would be nice if we could have the edit function back, I misspelled something and I can’t go back to correct it!


#16

@ Chris

Mousing over list entries you own will reveal an edit and delete icon.

You receive points upon creation. Editing modifies the points you’ve earned. Just to be clear you only earn points occasionally? I’ll be on chat for the rest of the day.


#17

So far, I have earned points every time, but I do think the limit on code should be higher.


#18

Hmm, I just submitted some code, and although it said I got points, they haven’t showed up yet. they don’t appear to be recalculated on login.


#19

This was related to a backend error. It’s fixed now. Please see http://www.tinyclr.com/forum/1/1603/ for further detail.