Main Site Documentation

VS2017 on Windows 7 not seeing G120 with 0.6.0 firmware and 2.0.4 Bootloader for USB Debugging


#1

VS2017 on Windows 7 is not seeing my G120 with 0.6.0 firmware and 2.0.4 Bootloader for USB Debugging. When I look at debugging in the project properties, the device name (G120_G120) is not showing. I tried reinstalling USB drivers. This is the only version of TinyCLR and Bootloader I have tried.

TeraTerm reports “1.02” and “BL” when I boot with LDR0 and LDR1 in “boot mode.”

Is VS2017 going to work for me on Windows 7? Or, does the .vsix only work for Windows 10?


#2

Can you properly enter and see BL2? The V command should give version 2.0.4. What shows up in the device manager when you try to enter BL1, BL2, and TinyCLR?


#3

I’ve had it working on both Windows 7, and Windows 10. After LDR0, and LDR1, you’ll need to put 2.0.4 bootloader on the device, and then reset it. You should see 2.0.4 when you get the version in Teraterm. After that you can load the G120 FW onto the device, and reset it.

Mine shows up correctly after that.


#4

The first thing you should always do is tell us what Device Manager shows. That’s a great hint at what state the device is in


#5

Hi,

When I cant see my board, i select serial and after usb in vs project properties in the netmf tab.


#6

It could be useful to show what Device Manager shows, not VS.


#7

It is good to know all the things I should have tried, and all the things I should have sent you. However, I didn’t do any of that. I solved the problem by using the TinyCLR-specific USB driver that Gus sent to someone with a similar problem.