VS2015 Cannot debug

Yes! I have read “As of today, we are only supporting Visual Studio 2013.”
My first usage of VS 2015 for NetMF

Installed Gary post GHI Electronics NETMF 2016 SDK Pre-Release 1
GHI Electronics NETMF SDK 2016 R1 Pre-Release 1
GadgeteerCore.msi

SDK: https://www.ghielectronics.com/support/netmf/sdk/39/ghi-electronics-netmf-sdk-2016-r1-pre-release-1
2015 .NET Gadgeteer Core: http://gadgeteer.codeplex.com/downloads/get/1519812

Yes! I have read “As of today, we are only supporting Visual Studio 2013.”

Using Windows 10 Pro

Using VS 2015 Community
NetMFVS14.vsix
.NET Micro Framework 4.3

Using G400-D Dev Board 1.0
Firmware 4.3.8.0

Ethernet application using EthernetBuiltIn

If I Build, Deploy Solution
the application runs as expected.

However I cannot Debug

Mostly information but I was wondering if any of the High Powered programmers
have found a way to Debug.

VS2015 Exception messages.

On first usage of Visual Studio 2015 using Net Micro 4.3

Attempting deployment…
Incrementally deploying assemblies to device
All assemblies on the device are up to date. No assembly deployment was necessary.
Assemblies successfully deployed to device.
Restarting interpreter…
Attaching to device…
Waiting for device to initialize…
The debugging target and the debugger engine failed to initialize because of unspecified device errors.
The debugger engine thread has terminated unexpectedly with error ‘Could not reconnect to the debugging target after rebooting it.’.

Just a question NOT a Gripe

Thanks

1 Like

@ andre.m -

Waiting for device to initialize…"

It all comes as a stream. No delay to speak of

I have not installed .netmf 4.4

I experienced the same issue :frowning: went back to vs 2013 in the end after GHI said 2016PR1 would not support VS2015…

@ willgeorge -

I seem to be having the same issue

If I open VS 2013, SAME project, debugs ok

If I run in VS 2015, The Cobra II board seems to drop USB connection and reset on debug…

I did an upgrade to latest firmware 4.3.8.0

Is VS 2015 supported or not???

It should be by now???
And how about .Net Frame Work 4.4? where is support for that?

@ networkfusion -

Thanks for post

So we still have to use VS 2013 in 2016!

Makes sense doesnt it!

@ PTSS -

Hmm just un installed .Net Micro 4.4 and for the first time it worked, got debug started.

Stop and now, cant get it to run in debug again

on Windows 10

Hi,

  • GHI Electronics NETMF SDK 2015 R1 (Aug 31, 2015) works and debug with VS2015
  • GHI Electronics NETMF SDK 2016 R1 Pre-Release 1 (Dec 24, 2015) works but not debug with VS2015

I test with :

  • Windows 7 x64
  • Windows 10 x64

So I uninstall SDK 2016 R1 Pre-Release 1 and re-install NETMF SDK 2015 R1 and all work fine.

Hello,

I have been having the same issue.

I dug into the Debugger code and found what seems to solve the problem for me.

CorDebugProcess.cs in C:\dotNet44\netmf-interpreter-dev\Framework\CorDebug
Note: this is netmf 4.4

I modified the lines at lines:439 and 448

and changed the Thread.Yield() to Thread.Sleep(10) in both cases.

Unfortunately you will need to rebuild the sdk for 4.3/4.4 and create a new NetmfVS14.vsix for this to work for you.
Maybe GHI can help?

cheers
dale

Hey… I still have VS 6.0 running, on my win 10 box (and vs 2008, vs 2013, and vs 2015)

I’m using VS2015 on Windows 10 without any issues.