Main Site Documentation

Visual Studio Productivity Power Tools can cause problems with Add Reference


#1

FYI, I ran into an issue while trying to Add Reference to a FEZ Domino project in Visual Studio 2010. I have Productivity Power Tools VS extension loaded. When I tried to add reference to GHIElectronics.NETMF.USBHost I was getting an incompatible library error and it wouldn’t let me add the assembly. It was complaining about .NET Micro Framework v4.1.2821.0 was not compatible with GHIElectronics v4.1.3.0. It was being very strict on the version number. This was using the Productivity Power Tools Searchable Add Reference Dialog.

To make it work I had to disable the Searchable Add Ref Dialog feature of Power Tools. Now I can add the references because it is using only major.minor version to determine compatibility. I’m going to send a bug report to Microsoft for this. I just wanted to let people know about this issue if someone else is having the same problem.

Cheers.


#2

Thanks for the feedback. We will also look into this on our end.


#3

Had the same issue and think we have a thread or post on this here somewhere. Your workaround is only way (afaict) to handle it. On that front, I wonder about those plugins. When you start having strange issues in the editor (i.e. brace completion, etc), it becomes difficult to tell if it is VS or some plugin code causing it without doing a dance. People start blaming VS in posts, when it is some plugin they forgot they installed 3 months ago. So it goes. :slight_smile:


#4

Yep, here it is:

http://www.tinyclr.com/forum/1/1236/


#5

One thing I have noticed is that, after installing the power tools, loading assemblies takes longer then before when deploying.

Are you experiencing this too?


#6

I have the same problem too! But after I updated to a new version it seemed to get much better!


#7

I have disabled it today. Hmm… maybe I should try an update too then? :think: