Visual Studio 2012 Debug Raptor

Ok,
Just got a Raptor and a new WiFiRS21, thanks to support for the help.

Everything worked great.

My original code was in 4.2 so I downgraded the Raptor to 4.2.11 and the code was ok, but I had the same problems as before with the WiFiRS21.

So I removed all the old 4.2 stuff from my system and reloaded 4.3 as per instructions on the page here.

Then I upgraded the Raptor to 4.3 using FEZ Config, No problems there.

Computer shows 4.3.6 and same on the Raptor.

So open the code in VS 2012, replaced the T35 display code and WiFiRS21 driver code.

Had a problem with deployment.

In debug I get…

Any ideas?

Thanks
Dan

Found debugger!

Create TS.

Loading start at 202d8818, end 20307cac

Assembly: mscorlib (4.3.1.0) Assembly: Microsoft.SPOT.Native (4.3.1.0) Assembly: Microsoft.SPOT.Security.PKCS11 (4.3
.1.0) Assembly: System.Security (4.3.1.0) Assembly: Microsoft.SPOT.Hardware (4.3.1.0)
Assembly: Microsoft.SPOT.Graphics (4.3.1.0) Assembly: Microsoft.SPOT.TinyCore (4.3.1.0)
Assembly: Microsoft.SPOT.IO (4.3.1.0) Assembly: System.IO (4.3.1.0) Assembly: Microsoft.SPOT.Hardware.Usb (4.3.1.0)
Assembly: Microsoft.SPOT.Hardware.SerialPort (4.3.1.0) Assembly: Microsoft.SPOT.Touch (4.3.1.0)
Assembly: Microsoft.SPOT.Ink (4.3.1.0) Assembly: Microsoft.SPOT.Hardware.PWM (4.3.1.0)
Loading Deployment Assemblies.

Attaching deployed file.

Assembly: Gadgeteer (2.42.0.0) Attaching deployed file.

Assembly: GTM.GHIElectronics.DisplayTE35 (4.3.6.0) Attaching deployed file.

Assembly: Gadgeteer.WebServer (2.42.0.0) Attaching deployed file.

Assembly: GTM.GHIElectronics.DisplayT35 (4.2.109.0) Attaching deployed file.

Assembly: Gadgeteer.SPI (2.42.0.0) Attaching deployed file.

Assembly: GHI.Hardware (4.3.6.0) Attaching deployed file.

Assembly: System (4.3.1.0) Attaching deployed file.

Assembly: GTM.GHIElectronics.USBClientDP (4.3.6.0) Attaching deployed file.

Assembly: GHIElectronics.Gadgeteer.FEZRaptor (4.3.6.0) Attaching deployed file.

Assembly: GHI.Usb (4.3.6.0) Attaching deployed file.

Assembly: GTM.GHIElectronics.WiFiRS21 (4.3.7.2) Attaching deployed file.

Assembly: Microsoft.SPOT.Net (4.3.1.0) Attaching deployed file.

Assembly: Gadgeteer.WebClient (2.42.0.0) Attaching deployed file.

Assembly: raptor1 (1.0.0.0) Attaching deployed file.

Assembly: GHI.Networking (4.3.6.0) Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘mscorlib’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Hardware.PWM’ (4.2.0.1)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.TinyCore’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Graphics’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Net’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Native’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.IO’ (4.2.0.0)

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘System.IO’ (4.2.0.0)

Assembly: GTM.GHIElectronics.DisplayTE35 (4.3.6.0) needs assembly ‘Gadgeteer’ (2.43.1.0)

Assembly: Gadgeteer.WebServer (2.42.0.0) needs assembly ‘mscorlib’ (4.2.0.0)

Assembly: Gadgeteer.WebServer (2.42.0.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: Gadgeteer.WebServer (2.42.0.0) needs assembly ‘System’ (4.2.0.0)

Assembly: Gadgeteer.WebServer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Native’ (4.2.0.0)

Assembly: Gadgeteer.WebServer (2.42.0.0) needs assembly ‘System.IO’ (4.2.0.0)

Assembly: GTM.GHIElectronics.DisplayT35 (4.2.109.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: GTM.GHIElectronics.DisplayT35 (4.2.109.0) needs assembly ‘mscorlib’ (4.2.0.0)

Assembly: GTM.GHIElectronics.DisplayT35 (4.2.109.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)

Assembly: Gadgeteer.SPI (2.42.0.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: Gadgeteer.SPI (2.42.0.0) needs assembly ‘mscorlib’ (4.2.0.0)

Assembly: Gadgeteer.SPI (2.42.0.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)

Assembly: GTM.GHIElectronics.USBClientDP (4.3.6.0) needs assembly ‘Gadgeteer’ (2.43.1.0)

Assembly: GHIElectronics.Gadgeteer.FEZRaptor (4.3.6.0) needs assembly ‘Gadgeteer’ (2.43.1.0)

Assembly: GTM.GHIElectronics.WiFiRS21 (4.3.7.2) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: GTM.GHIElectronics.WiFiRS21 (4.3.7.2) needs assembly ‘Gadgeteer.SPI’ (2.42.0.0)

Assembly: GTM.GHIElectronics.WiFiRS21 (4.3.7.2) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)

Assembly: GTM.GHIElectronics.WiFiRS21 (4.3.7.2) needs assembly ‘Microsoft.SPOT.Net’ (4.2.0.0)

Assembly: Gadgeteer.WebClient (2.42.0.0) needs assembly ‘mscorlib’ (4.2.0.0)

Assembly: Gadgeteer.WebClient (2.42.0.0) needs assembly ‘System.Http’ (4.2.0.0)

Assembly: Gadgeteer.WebClient (2.42.0.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: Gadgeteer.WebClient (2.42.0.0) needs assembly ‘System.IO’ (4.2.0.0)

Assembly: Gadgeteer.WebClient (2.42.0.0) needs assembly ‘Microsoft.SPOT.Native’ (4.2.0.0)

Assembly: raptor1 (1.0.0.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: raptor1 (1.0.0.0) needs assembly ‘GTM.GHIElectronics.DisplayT35’ (4.2.109.0)

Assembly: raptor1 (1.0.0.0) needs assembly ‘GTM.GHIElectronics.WiFiRS21’ (4.3.7.2)

Assembly: raptor1 (1.0.0.0) needs assembly ‘GTM.GHIElectronics.USBClientDP’ (4.3.6.0)

Assembly: raptor1 (1.0.0.0) needs assembly ‘GHIElectronics.Gadgeteer.FEZRaptor’ (4.3.6.0)

Assembly: raptor1 (1.0.0.0) needs assembly ‘Microsoft.SPOT.Net’ (4.2.0.0)

Assembly: raptor1 (1.0.0.0) needs assembly ‘Microsoft.SPOT.Graphics’ (4.2.0.0)

Error: a3000000

Waiting for debug commands…

The program ‘[2] Micro Framework application: Managed’ has exited with code 0 (0x0).

@ danmeland - It looks like your project is trying to deploy 4.2. I would make sure the project properties correctly show 4.3 and then remove and re-add any references.

John,

Thanks, and yes you are correct.
The Core was wrong. Thanks again.

I got it.

Dan