Main Site Documentation

Vb


#1

Hi Folks,

tried a VB Project, but …

He throw lot of errors, cause he don’t understand the standard character to start a comment???
After using the ancient style ‘REM’ this was fixed, but still more errors there.

Is this a silly bug, or is VB not really working?

I not only select netMF cause I should be able to use the existing VB code of my project (former runs under XP) and can start doing business as usual.

With best regards

Gerhard


#2

Post your code please…


#3

VB examples – follow the link “Visual Basic and Gadgeteer E-book” on the .NET Gadgeteer support page: https://www.ghielectronics.com/support/gadgeteer


#4

@ Gerhard - What is the standard character you are using? The single quote?


#5

yes, single quote


#6

Not to ask a stupid question, but was that the single quote ’ or the ` . They look similar, but the second is not actually the single quote used as a comment in VB.


#7

NETMF uses the standard VS compiler. There is no special compiler for NETMF so I do not see how this could happen!


#8

Now that’s some nice & concise SPAM. :smiley:


#9

They are trying hard aren’t they?


#10

I deleted his account


#11

Hi Folks,

sorry about the delay, was busy with other project.
I send the code,
It is the ‘Serial Communication Demo’ from the documentation, converted to VB with a code converter, just to have a nice starting point.

I replaced the single quotes with ‘REM’ just to see, if there were more issues. Unfortunately, there is a generated file also having comments, and so I stopped because this would be a never ending story.

So, the question about using just the wrong character is also answered, I hope that the code generator uses the correct one … hihi.

I also think, that the compiler used is the standard VB, and as I converted some notNETMF projects with this converter without problems over the years, I was totally astonished about that issue. It is really funny.

With best regards

Gerhard
Seems that the trick filename.zip.png doesnt work.

Ok, will send the Project, please tell me how.

PS: Hard to send a zip file, so how can I send a Project?


#12

… here an Image of the generated resource file and his Errors.

With best regards

Gerhard


#13

FIXED, here the answer from Tangible Software which creates this fine tool:

Hi Gerhard:

The project file issue has been fixed in the latest build which you can now download.
Thanks for reporting this issue.

Regards,
Dave
Tangible Software Solutions

With best regards

Gerhard


#14

@ Gerhard - That is great, but you have not told us what the issue was. Was it the wrong character that they emited, or was it something else?


#15

… sorry.

The project file wasn’t converted correct. This mislead the compiler and as a result we see very strange behavior.

Now this is solved and I will get the new version of the code converter this days and finally check out.

With best regads

Gerhard