V2-Preview 2 "...TinyCLR.Drawing" Working?

Thanks for the great stuff guys! Looks great. Camera looks great too :wink:
Both boards don’t seem to need any firmware updates, they both say they are up to date in CLR_Config (2.0.0.1)
Trying to load up the sample camera application from new-docs. Using preview2 Nuget files.
Got the following output on the build:

Found debugger!
Create TS.
Loading Deployment Assemblies.
Attaching deployed file.
Assembly: mscorlib (2.0.0.0) Attaching deployed file.
Assembly: GHIElectronics.TinyCLR.Drawing (2.0.0.0)
Error: the reference GHIElectronics.TinyCLR.Drawing cannot be used with this version of the firmware.
Firmware checksum 0x937F94D0 does not match the assembly checksum 0x01723A9C.
Resolving.
The debugging target runtime is loading the application assemblies and starting execution.
Ready.
Cannot find any entrypoint!
Done.
Waiting for debug commands…

And that lovely screen is now blank lol.

Is there an issue with the latest TinyCLR.Drawing nuget file? It is using the preview2 version.

Thanks.

John

PS - cant seem to be able to unbold the text above, sigh…

Sorry, I see that the current fimware is now 2.0.0.2, not 2.0.0.1, so thats probably the problem. But can’t update the board firmware (20260) to 2.0.0.2, TinyCLR says that the uploaded firmware file that I downloaded (SITCore Firmware v2.0.0-preview2.ghi) is corrupt. I have copied the GHI USB drivers over as noted by “csailor” in the getting started instructions, so I get not a “Com6” but a GHI Electonincs Bootloader Interface (Com6) now.

The TinyCLR firmware upgrade process worked fine when I tried it with the SC20100 board, it is now at 2.0.0.2, but going back to the SC20260, it still says corrupt firmware file, so it’s staying at 2.0.0.1 at this point… Both boards without any display connected to keep power consumption down.

Please update the firmware and ignore the version.

My only guess it is power issue

You can try:

  • Close TinyCLR Config, reopen again. This will help to release the com port.
  • Hold LDR0, hit and release reset.
  • Release LDR0

Those step will enter to bootloader mode directly.

  • Click on new port, make sure the device is in Loader mode
  • The version 2.1.0. Any older version won’t work.

I’ll suggest try different USB cables (no hub in between).

1 Like

Problem solved, it was an issue with the SITCore module.

1 Like