Main Site Documentation

Using Onboard Peripherals on FEZ Cobra II


#1

I am new to Micro Framework and saw that the Gadgeteer range offered what I needed for a new project. WiFi, RS232 and SD Card.
So I purchased Fez Cobra II (WiFi) and an RS232 module.
That mainboard is not supported in Visual Studio with the Gadgeteer 2014 R3 package so could not work out how to access the onboard WiFi because it was not a module.

So looking to swap this for a Fez Cobra II (Eco) without the WiFi and get a separate WiFi module so I can add the WiFi module in Visual Studio.

I’m happy doing that but still cannot see how I would begin to understand how to access the onboard SD card.

It must be easy when you know how but as a newcomer to Gadgeteer and Micro Framework I cannot work out where to start after hours of searching.

Thank you


#2

The Eco and the WiFi are identical boards. You can add the Eco in Gadgeteer designer and everything will work fine.

As for WiFi, see this please https://www.ghielectronics.com/docs/30/networking

You still need to know what pins go to WiFi. You can check the schematics and also someone else will reply with this detail for you so you can just wait.

Welcome to the community.


#3

@ mantracourt - You can find out more about working with WiFi on https://www.ghielectronics.com/docs/318/fez-cobra-ii-developers-guide

You can also look at the Mainboard object’s members for use of the SD Card. The Mainboard.SDCardMounted event should be helpful. It will give you a StorageDevice object that can be used to access files.


#4

Great. Thanks guys that really helped.


#5

Part of the way there but stuck further on.
I have successfully used the code to utilise the onboard WiFi module and that is OK to a point.
I manged to connect to a WiFi network with a simple text password.
But if I try to connect to the work network that uses a hexadecimal pass phrase it fails with Authentication error.
The passphrase for the network is something like 75AD54DFF98EC43A057EDD
but using that as the password the Join method fails with the exception error.

So I remembered that sometimes in WiFi the entered pass phrase in readable hexadecimal is actually used to generate the network key where ‘FF’ that you type is actually stored as a single byte in the key with decimal value 255.
(Some will recall the early days of networking where the prompt for the key was something like ‘Enter 128bit hexadecimal key or type a pass phrase’.
So I tried Joining using a string consisting of bytes to the value of the hexadecimal character pairs in the key. Still get the authentication error.
Anyone had issues with this?

As this is WPA 2 security I wondered if I needed to set the security type but after many hours of playing I cannot see how on earth to change the security settings for the WiFiRS9110 object I had created.

Im using Visual Basic so that may complicate things for you.

Thank you


#6

@ mantracourt - I believe there are some issues using WPA2. Could you try with just WPA?

It’s only with WEP do you need to encode the password as hex. WPA and WPA2 just use a plain string password. The security settings are shown in the NetworkParameters object you get from Scan or pass to Join.


#7

I have successfully joined an iPhone ‘hotspot’ with a 7 letter password which is WPA2.
I just cannot connect to my work access point which is also WPA2 but has a 32 character password.
I will need to experiment with a shorter key maybe but this is not easy to do at work as the Wi-Fi network is in use.
If anyone knows what issues there may be with WPA2 and passwords I would be grateful.


#8

@ mantracourt - You could quickly increase the password length of the iPhone hotspot to 32 characters and see if it still fails


#9

yeah I was going to say can you adjust the WPA2 key to be 31 or less characters. That number is just too “round” for me.


#10

If I set a 32 character key on the iPhone I can no longer connect.
Setting a 31 character key allows me to connect again.

So seems there is an issue somewhere that means the network key must be 31 characters or less to connect.

Thank you everyone