Main Site Documentation

Using NETMF 4.3 and GenericDaisyLink


#1

Hi, I bought a Mountaineer Ethernet board, a MaxO and a DL40. I flashed the mainboard to NETMF 4.3. In order to use the modules, I needed to download the gadgeteer source from codeplex, copy the MaxO/DL40 solutions, retarget them to NETMF 4.3, and use the resulting libraries in my project. The MaxO had some compile errors which were not hard to fix, the DL40 compiled without further changes.

Now when I instanciate the modules in my code, the MaxO works without any problems, I can flash Leds on and off. But the creation of the DaisyLink module fails with the exception:

I tried different sockets, but it always results in the same error. Do I have to change anything on the DL40 in order to make it NETMF 4.3 compatible? What other sources of error could be involved?


#2

I would reflash DL40 to make sure it has the right application on it.


#3

Does I2C otherwise work on the board?


#4

@ John: I have no idea. The only modules at hand are a MaxO and the DL40.

@ Architect: How do I do that? I’m a reflash noob. I thought at least enough code in order to be functional with the example code in the resources section would be on the device when it ships.

@ GHI: In general, are you planning to compile your gadgeteer modules for NETMF 4.3 in the near future?