Main Site Documentation

Usbizi without Bootloader (Fez Panda)


#1

I’m attempting to support a legacy project that is driven by the USBizi chipset. We bought a handful of old Fez Panda boards hoping to remove the processor and put it on our custom board. Before we did that, I wanted to test the chip to make sure it worked. Using FezConfig I was able to see the USBizi and confirm that it does not have a bootloader installed and the current firmware version is 4.1.3. I need to update the firmware to 4.1.8 to work with my source code. How would I accomplish this without a bootloader?


#2

Use a terminal software and open the serial port showing by usbizi, when it is in loader mode. Then hit V to see version and make sure there is communication back. Then hit X and you will see CCCCCC… coming back, now transfer a firmware using X modem 1K settings.


#3

The Panda board doesn’t create a virtual COM port when I plug it in via the usb. I tried connecting to the COM1 IN and OUT pins on the board, but I don’t get any output on those pins when the board is reset.


#4

Did you put the board into boot loader mode ?


#5

Ok, I got the GHI Bootloader serial port to show up. I’m using Tera Term as my terminal application. It fails when trying to open the GHI serial port. I get a “Cannot Open COM26” error. I got the same error with both Panda boards I tried.


#6

Do you have a new version of teraterm?


#7

I’m using version 4.84, which isn’t the newest…but almost.


#8

Should I be using an old version?


#9

I’d suggest 4.53. I’m using it (and still using plenty of USBizi’s).

BTW if you wanted USBizi144’s I have a handful in a frame that are never likely to get used. Or maybe I should open the Domino PCB and make up some boards with more IO.


#10

The old USBizi page https://www.ghielectronics.com/docs/53/firmware-update-usbizi points to the original 4.53 location but it’s giving a file-not-found error, can someone from GHI redirect that to the current location ?


#11

The oldest version I could find on their website was 4.69, but that did the trick anyway. I was able to update the firmware and flash my application to the chip.

Thanks everyone for your help!


#12

@ Brett - I checked the links on the page https://www.ghielectronics.com/docs/53/firmware-update-usbizi , but couldn’t find any mis-directed link? It’s possible somebody else at GHI already fixed what you are describing; but, just to be sure, could you quote me the one you described?

As to Teraterm 4.53, it is the one documented as “tested;” it is the one I use; I’m hesitant to install/link-to an untested newer version.


#13

@ Jeff - I fixed it earlier but forgot to reply here.


#14

@ John - LOL. Josh fixed some items as well.