Main Site Documentation

USBizi Vista 32bit driver location


#1

Before I went on vacation I was happily experimenting with WiFi code using a FEZ Domino and Sparkfun WiFly Shield. Today I’m back to that project but have a driver issue when trying to connect the FEZ Domino to Vista (32bit).

When I connect the Domino to USB, Vista installs the GHI USB driver and the CDC driver, but now it’s asking for the USBizi driver. I’ve tried to locate the appropriate inf file, but cant find one that works. Uninstalling GHI software, rebooting and reinstalling hasn’t helped.

Another odd thing is that I can get the Domino into bootloader mode, and Vista loads the appropriate GHI bootloader driver. Within TeraTerm the version responds with 1.07 and I can start Xmodem transfer, but when sending the firmware file the Domino disconnects and reconnects to USB and hence fails to transfer the firmware :frowning:

Is there a USBizi Vista driver? If so where would it be in relation to default installation directories?

EDIT:
I managed to make some progress by using the ‘D’ option of the boot loader, as described in the “Emergency user application code deletion” section of the FEZ_Tutorial.pdf
I was able to reflash the firmware, then could ‘Ping’ via MFDeploy and step into my app. But now I face “Device not found or cannot be opened - USB:USBizi” problems :frowning:

RESOLVED:
I needed to do another erase of application code, but since then Domino has been behaving nicely. Now to flesh out more of my WiFly code :slight_smile:


#2

glad you have it working and now we are writing to see some progress on the wifly board. This will be beneficial to a lot of users.

If you manage to write a good driver that is approved by our community to be usable and complete, and you have a telnet of web server example then I will give you 1000 points on top of what you will get from fezzer when you add the driver :wink:

I think this should look like this…just an idea

WiFly.Init(“COM1”, Protocol.TCP, int16 port_number_80);
WiFly.DataRecievedEvent += myEvent;
WiFly.Send("…");

If you are using the shield then there is a SPI-UART chip on the board but this is very bad since it is much better to just use one of the many serial ports on FEZ.

The only reason th shield has SPI-UART chip is that Arduino only has one serial port which is used for deploying programs!


#3

Thank you for the reply Gus. I’ve made some nice progress today. I have a test project and WiFly class library ready to upload to github (or google code?).

At the moment you use the following calls;


            if (WiFly.Shield.Setup(
                        (Cpu.Pin)FEZ_Pin.Digital.Di10, 
                        SPI.SPI_module.SPI1, 
                        WiFly.Shield.ClockRate.Xtal_12Mhz, 
                        3, false) == false)
            {
                Debug.Print(WiFly.Shield.GetError() + "\n");
                Thread.Sleep(Timeout.Infinite);
            }

            if (WiFly.Shield.JoinNetwork(
                        ssid, 
                        passphrase, 
                        WiFly.Shield.AuthenticationType.MIXED_PSK,
                        80) == false)
            {
                Debug.Print(WiFly.Shield.GetError() + "\n");
                Thread.Sleep(Timeout.Infinite);
            }

This WiFly class library started life as the driver C# code found here on tinyclr. So there are also publically exposed functions for SendCommand, WaitForResponse, etc.
Posts on this forum, and some Arduino WiFly work on other forums, has helped me get this far. I may be able to find time to add further example code to the test bed, or leave that to others?
Hopefully I can get all this uploaded and a link posted in a new forum thread.


#4

Richard4,

instead of github or googlecode, use TinyCLR’s own fezzer: http:www.fezzer.com

Just a matter of keeping Fez and NetMF related code centralized.

Greetings,
Eric


#5

Nice one Eric. Thanks for pointing out that site. Looks like an easier way to share FEZ code.

After looking through some examples, I now wonder if there is a particular namespace convention required?


#6

My current ‘simple’ version is now up on Fezzer :slight_smile:
http://www.fezzer.com/project/168/sparkfun-wifly-shield-with-fez-domino/


#7

I’m trying to get this same shield working for the Panda and haven’t been able to yet. I realize (too late) that I bought the wrong shield and should have just got the one that exposes all the pins instead of the SPI stuff. That being said it seems like I should be able to get this thing to work. I had to connect a jumper from 3.3V to Vin and that got the lights blinking. I’ve taken the code from Fezzer and removed a bunch of stuff that wasn’t needed to get it to compile ok.

It is using Di10 as the chip select is that correct? From looking at the Panda schematic, Di13-11 are the SPI ports so I’m not sure what chip select means but I tried Di 13-9 to no avail. Using Di 13-11 gives an errors on SPI registration, 10 and 9 seem to work but reads don’t ever return any data. Just for grins I completely unnplugged the shield and the behavior was the same as using 10 or 9 for chip select - no errors on registration or writes but reads don’t get any data.


#8

Sorry My bad I thought this is an Arduino wifi shield!

http://www.tinyclr.com/forum/1/1439/#/2/