Main Site Documentation

USBizi stand alone chip found as Unknown Device


#1

Hey guys,

I am using the 100 pin USBizi chip in my device. The problem I face is as follows: When the usb cable is plugged, my Device manager recognizes the chip as Unknown Device.
I have installed .NET Micro and the GHI Gadgeteer from here: http://www.tinyclr.com/support/
The schematic implementation for the USB is based on Panda’s schematic - http://www.ghielectronics.com/downloads/FEZ/Panda/FEZ_Panda_sch.pdf (with this difference that R19 is connected directly to Vcc, so I don’t use USB_CON pin (64))
The interesting moment is that in the beginning the PC recognized it as GHI device and tried to install the drivers but couldn’t so it “changed its mind” and since then - Unknown Device.
As a reference:

  1. this is the second chip I use. The first one worked under the same configuration (it was recognized as COM), but I cannot use it anymore (broke the VBUS pin :slight_smile: )
  2. I have also one FezPanda and it works fine (recognized as USB port)
  3. I also connect one ChipwokX and it also works properly (recognized as COM).

Maybe I should also mention that BL# and MODE pins (53 and 70) are not connected

Any suggestions what can be the problem? Tried to restart, to change the USB port and connected it also to another computer - nothing.


#2

Compare your schematics to one of our boards. Also, please try serial debugging as well.

Welcome to the community.