Main Site Documentation

USB serial port not available when FEZ is plugged in


#1

Plug in Arduino micro, /dev/tty.usbmodem1421 appears.
Unplug, it disappears.
Plug in FEZ, it does not reappear.

OSX 10.8.4
MacBook Air 11"
Latest version of Arduino

Any ideas, guys?


#2

Did you attempt to use another USB port or even a powered HUB?


#3

Hi spongefile & James.

I have the same thing happening with my iMac running OS X 10.9.

Doesn’t matter where I plug in the Medusa S12/mini (port or powered hub) it is not recognised by my Mac.

I have no problem with the Medusa shield plugged into a UNO and
the Mac recognises other GHI boards such as the G400, Carb, etc.

I have tried two different Medusa S12’s and a mini same thing! Not recognised!

All other boards (like UNO, G400 etc) are listed on the system report connected to the appropriate hub. The Medusa’s are not listed when connected.

Hope GHI can help Mac Arduino users.

Paul.


#4

The 11" Air has only one USB port, but I’ll go get a powered hub and try with that.


#5

We have a Mac and plan on dong plenty of testing there but this come right after we complete all the Software and labs for the whole package.

It should be some minor things.


#6

Bought best powered hub I could find, Mac still can’t see it. Hope you guys figure this one out, I’m itching to get started with this stuff!


#7

Hello Again.

I have only just gotten back from a trip to Europe and just had another go at getting my new GHI Arduino toys working with the Mac.

I have discovered that my particular problem was caused by a faulty USB-Serial SP module I had screwed onto a holyboard along side an S12. When I swapped the power module out with another unit, it worked! When I tested the original US-SP on another machine it did power-up the Spider but the FTDI interface wasn’t recognised by the PC.

Problem solved - for me anyway.

I hope to have some time over the coming weeks to do some more experimenting.

Paul


#8

Just noticed that the Adafruit GEMMA doesn’t work with the Macbook Air because the Air’s ports are USB v3 and GEMMA needs USB v2. Will try to see if using a v2 hub makes both the GEMMA and the FEZ work.