USB Mini B Pinout

I have built a pcb with the 100 pin USBizi chip. I cannot get the board to respond to MFDeploy. I am reasonably sure I have the Mini B connector correct, but could someone verify?

Looking into the Mini B connector on my board, pin 1 is on the left and pin 5 is on the right. Pin 1 is Vbus, pin 2 is DM, pin 3 is DP, and pin 5 is ground. DP goes to the USBizi pin 29 and DM goes to pin 30.

All the voltages are at +3.29 volts. I have the exact usb interface as on the Panda board. (see attached jpg)

Can someone verify that this is correct. I am stumped by this simple device.


The picture states pin 1 is on the right. That is incorrect. I beleive pin 1 in on hte left

Do not count pins as they show on schematics. Search the web for pinout or look at the traces on our board under a magnifier

If I remember correctly then pin 1 is on the left, looking into the connector.

But I must say, I have never paid much attention to the location of pin1, I always just trust eagle’s pinout and it has always worked… :slight_smile:

Tried all of the above, except Eagle. Just hoping I had overlooked the obvious.

Will try Eagle.


Google is i an engineer’s best friend!


Of course I googled the connector, but I did not get this site.

I am sure my problem will be very obvious, when it is found!!

Are the USBizi100 (non-commercial)chips programmed and ready to develope code? I have physically checked this new board out, and I find all components, traces and voltages are correct.

The pnp transistor that is for turning voltage on to D+ of the mini usb connector is not turning on, thus no voltage on D+.

On the Panda, VBus/E36* pin 65 is used to sense the usb 5.0 volts and the processor turns on pin 64 USB_Con.

On the Mini, VBus/E36* pin 65 is used to sense the usb 5.0 volts and the processor turns on pin 64 USB_Con.

On the USBizi Dev-Sys 1.1 document dated 09/25/2008 on the GHI website, VBus goes to pin 40 and USB_Con2 goes to pin 48.

I used the Panda and the Mini pin configuration, but even though the VBus is at 5.0 volts USB_Con remain at 2.85 volts, never going low, thus not turning on the transistor and the voltage.

The USBizi 100 pin chip in use was purchased from GHI - designated USBizi100 (non-commercial).

Am I on the right pins? Are these chips ready to develop code, or is there a step I am missing?


Why not try the serial interface? You need to connect mode to ground

Hi bdrew,

I would like to know how u get rid of the situation when USB_CON gives a 2.85V. How u made the PNP transistor ON in the final working device.