Main Site Documentation

USB device not recognized after Cerb firmware update to 4.3.3


#1

Okay guys, this is repeatable. I’ve tried on two different computers (both Win7 Pro), used two different USB cables, and two different Cerb boards (Cerb Bee and Cerb40)…

Both boards had 4.2.6.1 on them and were recognized before the firmware update began. I used the STM Tester to update the TinyBooter on both with no issues. I then used FEZ Config to update the firmware to 4.3.3.0 (latest). At the end of the process I get the Success message, the device restarts, and then I get the USB device not recognized error from the system tray notification. I’ve tried the same process several times on both boards with the same results.

I poked around the forum and found a couple other similar threads. The only advice given was “reload the firmware” :wall:

Any ideas?


#2

We did not change the usb drivers iirc. But I think we have one machine with similar behavior. We will investigate further.

The device works fine on other machines right?


#3

No, two different computers, same behavior. One laptop with USB3, and one PC with USB2. I have to reload the TInyBooter each time to get FEZ config to recognize the devices.


#4

What happens if you manually update the driver to use WinUSB?


#5

Intel or amd?


#6

@ Bill - ‘best driver is already installed’

@ Gus - both Intel


#7

@ ransomhall - yeah i know it thinks it’s clever even with my awesome original Win3.1 code base…

Forcing the WinUSB update works for me…


#8

@ ransomhall - When you look at the device properties in the device manager for the unknown device, does it show something like device cannot start, code 10 or 43?


#9

@ John - Code 43 it is…

“Windows has stopped this device because it has reported problems. (Code 43)”


#10

@ ransomhall - That’s an issue we have seen a few times now. We are looking into it but so far the only way to get around it is to try to use a different computer.


#11

I got that message from trying it on my third different computer. I don’t have any more to try it on… let me know if you need some specifics about my environments to help narrow it down.


#12

I faced same problem on one of my Cerberus … Till now I couldn’t find any solution. WinUSB is not responsible. Now I’m using the specific Cerberus with native code, no more netmf and it works fine.
I reported here:
https://www.ghielectronics.com/community/forum/topic?id=16386

EDIT: Funny enough, if I flash 4.3.2 (beta) it works fine. So it is a problem on 4.3.3.


#13

I think this is fixed in next release


#14

This issue is indeed fixed in 4.3.4.0. The cerb40 I upgraded now happily appears as “Cerb-Family (non-commercial use)_Gadgeteer” after the update. Nice friendly name BTW ::slight_smile: