Main Site Documentation

Updating Tinybooter USB Issue on Spider - New


#1

Hi all,

OK, so I just got into gadgeteering when I got a FEZ spider kit the other day but still haven’t been able to use it. My issue is that I’m getting a USB device descriptor error when booting into bootloader mode to update tinybooter.

My Win 8.1 Pro laptop (w/ USB 3.0) can see the device properly when in normal config setting but not in bootloader. I have VS 2012 Desktop express and using FEZConfig to update. I only connected the DP client to the spider (no other modules). I manually installed both USB drivers from GHI USB folder.

I went out and purchased a powered USB 2.0 hub and tried that and still no luck, also tried different cables, external power source, but still no joy.

Any ideas?


#2

Hi, same problem here.

I´m trying to update the TinyBooter but the FEZ spider is not recognized in loader mode. I have tried different computers (Windows 7 64Bit USB 3.0, Windows 7 64Bit USB 2 and Windows 7 32bit USB 1 and USB 2, Windows 8 32Bit USB 3), with or without external power supply.

In normal mode or TinyBooter mode the Spider is recognized correct on all computers.

Is it correct that a connected display in loader mode shows for 2 seconds EMX TinyBooter mode (Version 4.1.6.0 …) and then fades to a white background?

Thanks and regards.


#3

Maybe you just need to load the driver manually. What do you see in the device manager?


#4

Thanks andre.m.

Hi Gus, I did install the drivers manually by Browse to GHI USB driver folder > Right click .INF file > Install. I did this for both the Bootloader and the NETMF driver prior to connecting DPClient and FEZ.

The message I get in Windows after changing the config switches and pressing Reset is “The last USB device you connected to this computer malfunctioned, and Windows does not recognise it.” In Device Manager I get “Unknown USB Device (Configuration Descriptor Request Failed)” - Error Code: 43.

To cover all bases I did try using the manual Bootloader deploy method but didn’t work because there was no COM device .

Based on the errors, the OP (Dan Kroymann) in this thread is identical to my issue: https://www.ghielectronics.com/community/forum/topic?id=9587&page=1

Thanks.


#5

How do you set your device in boot loader? Did you try a different usb cable?


#6

Hi @ Gus, with the D/1 socket pointing North; the 3 right most config switches (1,2,3) turned On (south position). Flicking 1 => 3 consecutively.

Tried different cables with no luck.

~ Chris


#7

I’m not sure if it’s anything but config switch 1 seems ridiculously hard to switch to on compared to the rest of the config switches.


#8

@ ontologia - Can you try to completely uninstall everything related to our SDK and uninstall the device from the device manager, making sure to delete the driver files if prompted, and then install our SDK again and see if it works?


#9

Hi @ John, during my attempts to get it working I did reformat my laptop and do a fresh install of everything - exact same issue before and after.


#10

Bam! Hoverboard!

Firmware deployed. I dug out an older laptop and installed VS2012 Express and R2 Gadgeteer things and it worked first go. So thanks all for the suggestions.

The older laptop was still running Windows 8.1 Pro…

Let the games begin!