Main Site Documentation

Updating boot loader on Raptor


#1

Hi Everyone,
Just purchased my first gadgeteer board (Raptor) and set of modules a couple weeks ago. Things have been going pretty well using the CLR and Bootloader that were preinstalled on the board (4.2.11.1). However, I was having some stability issues with I2C when using the T43 display that I was hoping would go away using 4.3 and the new R2 Beta-3 gadgeteer package. So I decided to go ahead and try to update…

Anyhow, my problem is that I cannot seem to update the bootloader. I have tried this on two different machines and each gives the same problem. Both are windows 8 x64. Both are a fresh install of the Beta-3 gadgeteer package.

After shorting pins 8 and 10 on socket 3 and entering bootloader mode, I am able to see a new comm port in the device manager. However, when I run Update.bat (in C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\G400\Loader) as administrator, I receive an error in the tcl script (image attached). The contents of the log file are:

-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA 2.12 on : windows
current connection is \USBserial\COM8, \USBserial\COM8 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM8
-I- argv 1 : at91sam9g15-ek
-I- argv 2 : Loader.tcl

I get a similar error if I try to connect using SAM-BA directly.
I should say that I was messing around with FezConfig and accidentally updated the Firmware to 4.3 before getting the boot loader updated. So now I have TinyBooter 4.2.11.1 and TinyCLR 4.3.2.0 on the device.

Any suggestions about how to get TinyBooter up to date?

I hope that I have provided enough info. My experience is in PIC32 programming and this is my first round at NETMF, etc.

Thanks in advance…
Scott


#2

welcome to the forum !!

The instructions (https://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400) do explicitly mention uppercase COM in the command, but for giggles can you try with lowercase?

Can you also show us a screenshot of the Device Manager serial ports ? That may highlight what is going on…

One final check, you did get an administrative rights command prompt to run this command, correct?


#3

Hey Brett,
Thank you very much for the quick reply. Actually, I got a bit frustrated and just re-installed everything. It works now. I really don’t know what was going wrong.

Onward!

Scott


#4

Awesome, now go make awesome stuff ! :slight_smile: :smiley: